summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..8fdc9ef
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,26 @@
+AC_INIT([src/u_boot.c])
+AM_INIT_AUTOMAKE([u-boot], [0.0.1])
+AM_CONFIG_HEADER([config.h])
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+AC_HEADER_STDC
+
+AC_CHECK_HEADERS([unistd.h errno.h time.h stdint.h stdlib.h alloca.h \
+string.h fcntl.h ctype.h zlib.h sys/types.h sys/stat.h sys/mount.h \
+sys/ioctl.h mtd/jffs2-user.h mtd/mtd-abi.h], [], AC_MSG_ERROR([
+required header missing]))
+
+AC_CHECK_LIB([z], [crc32], [], AC_MSG_ERROR([libz is required]))
+
+AC_DEFINE([DEBUG], 0, [set to 1 to enable debug])
+AC_DEFINE([MTD_ENV1], "/dev/mtd3", [set to the first u-boot env mtd])
+AC_DEFINE([MTD_ENV2], "/dev/mtd4", [set to the second (redundant) u-boot env mtd])
+AC_DEFINE([MTD_SIZE], 0x20000, [size of u-boot env mtd])
+AC_DEFINE([DEFAULT_ENV], ["bootargs=mem=64M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2\0" "bootcmd=nboot.jffs2 ${loadaddr} 0 ${kernel_addr}; bootm ${loadaddr}\0" "bootdelay=3\0" "baudrate=115200\0" "ethaddr=00:D0:A0:02:0D:E1\0" "ipaddr=192.168.2.1\0" "serverip=192.168.2.2\0" "netmask=255.255.255.0\0" "hostname=AT91SAM9G20\0" "loadaddr=0x21400000\0" "kernel_addr=0x000A0000\0" "\0"]
+, [default env if corrupt])
+
+AC_OUTPUT([Makefile src/Makefile])
+