summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5e6a888
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,31 @@
+AC_INIT([softdog-mon],0.1.0)
+AC_CONFIG_SRCDIR([src/softdog-mon.c])
+AM_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE
+
+
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+AC_HEADER_STDC
+
+AC_CHECK_HEADERS([ \
+sys/types.h \
+sys/stat.h \
+sys/ioctl.h \
+linux/watchdog.h \
+fcntl.h \
+stdio.h \
+string.h \
+errno.h \
+stdlib.h \
+unistd.h \
+], [],AC_MSG_ERROR([
+required header missing]))
+
+AC_DEFINE([DEBUG], 0, [set to 1 to enable debug])
+
+AC_OUTPUT([Makefile src/Makefile])
+