summaryrefslogtreecommitdiff
path: root/meta/packages/oprofile/oprofile_0.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/oprofile/oprofile_0.9.6.bb')
-rw-r--r--meta/packages/oprofile/oprofile_0.9.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/packages/oprofile/oprofile_0.9.6.bb b/meta/packages/oprofile/oprofile_0.9.6.bb
new file mode 100644
index 0000000000..29c3f1bb7f
--- /dev/null
+++ b/meta/packages/oprofile/oprofile_0.9.6.bb
@@ -0,0 +1,22 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+DEPENDS = "popt binutils"
+RDEPENDS = "binutils-symlinks"
+RRECOMMENDS = "kernel-vmlinux"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+ file://opstart.patch \
+ file://acinclude.m4"
+S = "${WORKDIR}/oprofile-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-kernel-support --without-x"
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}