summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xbitbake-dev/bin/bitbake5
-rw-r--r--bitbake-dev/lib/bb/ui/ncurses.py3
2 files changed, 3 insertions, 5 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index 87284c08fe..ea4147e971 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -123,7 +123,6 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
-
# Work out which UI(s) to use
curseUI = False
depexplorerUI = False
@@ -168,10 +167,6 @@ Default BBFILES are the .bb files in the current directory.""" )
# Launch the UI
try:
- # Disable UIs that need a terminal
- if not os.isatty(sys.stdout.fileno()):
- curseUI = False
-
if curseUI:
try:
import curses
diff --git a/bitbake-dev/lib/bb/ui/ncurses.py b/bitbake-dev/lib/bb/ui/ncurses.py
index 1476baa61f..866792b14f 100644
--- a/bitbake-dev/lib/bb/ui/ncurses.py
+++ b/bitbake-dev/lib/bb/ui/ncurses.py
@@ -324,6 +324,9 @@ class NCursesUI:
pass
def init(server, eventHandler):
+ if not os.isatty(sys.stdout.fileno()):
+ print "FATAL: Unable to run 'ncurses' UI without a TTY."
+ return
ui = NCursesUI()
try:
curses.wrapper(ui.main, server, eventHandler)