summaryrefslogtreecommitdiff
path: root/scripts/lib/recipetool/newappend.py
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-12-14 21:13:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-16 08:30:03 +0000
commit0a36bd96e6b29fd99a296efc358ca3e9fb5af735 (patch)
treee6eda6f73d4f8cca573b5061f2511ec89705cba4 /scripts/lib/recipetool/newappend.py
parent7c552996597faaee2fbee185b250c0ee30ea3b5f (diff)
downloadopenembedded-core-0a36bd96e6b29fd99a296efc358ca3e9fb5af735.tar.gz
openembedded-core-0a36bd96e6b29fd99a296efc358ca3e9fb5af735.tar.bz2
openembedded-core-0a36bd96e6b29fd99a296efc358ca3e9fb5af735.zip
scripts: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'scripts/lib/recipetool/newappend.py')
-rw-r--r--scripts/lib/recipetool/newappend.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/recipetool/newappend.py b/scripts/lib/recipetool/newappend.py
index 376084035f..0b63759d8c 100644
--- a/scripts/lib/recipetool/newappend.py
+++ b/scripts/lib/recipetool/newappend.py
@@ -60,7 +60,7 @@ def newappend(args):
if not path_ok:
logger.warn('Unable to determine correct subdirectory path for bbappend file - check that what %s adds to BBFILES also matches .bbappend files. Using %s for now, but until you fix this the bbappend will not be applied.', os.path.join(args.destlayer, 'conf', 'layer.conf'), os.path.dirname(append_path))
- layerdirs = [os.path.abspath(layerdir) for layerdir in rd.getVar('BBLAYERS', True).split()]
+ layerdirs = [os.path.abspath(layerdir) for layerdir in rd.getVar('BBLAYERS').split()]
if not os.path.abspath(args.destlayer) in layerdirs:
logger.warn('Specified layer is not currently enabled in bblayers.conf, you will need to add it before this bbappend will be active')