summaryrefslogtreecommitdiff
path: root/openembedded/packages/python/python_2.4.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-26 13:28:14 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-26 13:28:14 +0000
commit1cd244533c2436e27a974d7c6a15262be7a49f50 (patch)
treec86f52fe49cfb4421a581f9cd7b9f65dfaea9a2e /openembedded/packages/python/python_2.4.3.bb
parent39811ea4ae7f49ce27b6206727ffd929aed986dd (diff)
downloadopenembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.tar.gz
openembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.tar.bz2
openembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.zip
Create openembedded-extras collection. Disabled by default - see local.conf.sample about how to enable
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@429 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/python/python_2.4.3.bb')
-rw-r--r--openembedded/packages/python/python_2.4.3.bb70
1 files changed, 0 insertions, 70 deletions
diff --git a/openembedded/packages/python/python_2.4.3.bb b/openembedded/packages/python/python_2.4.3.bb
deleted file mode 100644
index 30ce73abe2..0000000000
--- a/openembedded/packages/python/python_2.4.3.bb
+++ /dev/null
@@ -1,70 +0,0 @@
-DESCRIPTION = "Python Programming Language"
-HOMEPAGE = "http://www.python.org"
-LICENSE = "PSF"
-SECTION = "devel/python"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
-DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml3"
-
-PYTHON_MAJMIN = "2.4"
-
-SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://crosscompile.patch;patch=1 \
- file://fix-tkinter-detection.patch;patch=1 \
- file://sitebranding.patch;patch=1"
-S = "${WORKDIR}/Python-${PV}"
-
-inherit autotools
-
-EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \
- --without-cxx --with-signal-module --with-wctype-functions \
- --enable-shared"
-
-#
-# copy config.h and an appropriate Makefile for distutils.sysconfig
-# which laters uses the information out of these to compile extensions
-#
-do_compile_prepend() {
- install -d ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
- install -d ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
- install -m 0644 pyconfig.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
- install -m 0644 Makefile Makefile.orig
- install -m 0644 Makefile Makefile.backup
- sed -e 's,${includedir},${STAGING_INCDIR},' < Makefile.backup > Makefile
- install -m 0644 Makefile Makefile.backup
- sed -e 's,${libdir},${STAGING_LIBDIR},' < Makefile.backup > Makefile
- install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
-}
-
-do_compile() {
- oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
- HOSTPYTHON=${STAGING_BINDIR}/python \
- STAGING_LIBDIR=${STAGING_LIBDIR} \
- STAGING_INCDIR=${STAGING_INCDIR} \
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
-}
-
-do_stage() {
- install -m 0644 Include/*.h ${STAGING_INCDIR}/python${PYTHON_MAJMIN}/
- oe_libinstall -a -so libpython2.4 ${STAGING_LIBDIR}
-}
-
-do_install() {
- install -m 0644 Makefile.orig Makefile
- oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
- HOSTPYTHON=${STAGING_BINDIR}/python \
- STAGING_LIBDIR=${STAGING_LIBDIR} \
- STAGING_INCDIR=${STAGING_INCDIR} \
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- DESTDIR=${D} install
-}
-
-include python-${PV}-manifest.inc
-
-RPROVIDES_python-core = "python"
-RPROVIDES_python-curses = "python"
-PACKAGES =+ "libpython2"
-FILES_libpython2 = "${libdir}/libpython*"