summaryrefslogtreecommitdiff
path: root/openembedded/packages/alsa/alsa-utils_1.0.10.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-12-15 17:50:54 +0000
committerRichard Purdie <richard@openedhand.com>2005-12-15 17:50:54 +0000
commit47eec0a88c2478c3da1c9607d549a5a95424fe1d (patch)
tree658cc436fc808a712c86c0b0508881512b2d463c /openembedded/packages/alsa/alsa-utils_1.0.10.bb
parentb38f2a5935beaa588b90eec63fa5ab56d084f822 (diff)
downloadopenembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.tar.gz
openembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.tar.bz2
openembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.zip
Add Alsa support to poky
git-svn-id: https://svn.o-hand.com/repos/poky@198 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/alsa/alsa-utils_1.0.10.bb')
-rw-r--r--openembedded/packages/alsa/alsa-utils_1.0.10.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/openembedded/packages/alsa/alsa-utils_1.0.10.bb b/openembedded/packages/alsa/alsa-utils_1.0.10.bb
new file mode 100644
index 0000000000..916afedd16
--- /dev/null
+++ b/openembedded/packages/alsa/alsa-utils_1.0.10.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "ALSA Utilities"
+MAINTAINER = "Lorn Potter <lpotter@trolltech.com>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib ncurses"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2"
+
+inherit autotools
+
+# This are all packages that we need to make. Also, the now empty alsa-utils
+# ipk depend on them.
+
+PACKAGES += "alsa-utils-alsamixer"
+PACKAGES += "alsa-utils-midi"
+PACKAGES += "alsa-utils-aplay"
+PACKAGES += "alsa-utils-amixer"
+PACKAGES += "alsa-utils-aconnect"
+PACKAGES += "alsa-utils-iecset"
+PACKAGES += "alsa-utils-speakertest"
+PACKAGES += "alsa-utils-aseqnet"
+PACKAGES += "alsa-utils-alsactl"
+
+
+# We omit alsaconf, because
+# a) this is a bash script
+# b) it creates config files for RedHat, Debian, Mandrake etc, but not
+# for Familiar, OpenZaurus etc
+
+
+FILES_${PN} = ""
+FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord"
+FILES_alsa-utils-amixer = "${bindir}/amixer"
+FILES_alsa-utils-alsamixer = "${bindir}/alsamixer"
+FILES_alsa-utils-speakertest = "${bindir}/speaker-test"
+FILES_alsa-utils-midi = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bindir}/amidi"
+FILES_alsa-utils-aconnect = "${bindir}/aconnect"
+FILES_alsa-utils-aseqnet = "${bindir}/aseqnet"
+FILES_alsa-utils-iecset = "${bindir}/iecset"
+FILES_alsa-utils-alsactl = "${sbindir}/alsactl"
+
+DESCRIPTION_alsa-utils-aplay = "play (and record) sound files via ALSA"
+DESCRIPTION_alsa-utils-amixer = "command-line based control for ALSA mixer and settings"
+DESCRIPTION_alsa-utils-alsamixer = "ncurses based control for ALSA mixer and settings"
+#DESCRIPTION_alsa-utils-speaker-test= "??"
+DESCRIPTION_alsa-utils-midi = "miscalleanous MIDI utilities for ALSA"
+DESCRIPTION_alsa-utils-aconnect = "ALSA sequencer connection manager"
+DESCRIPTION_alsa-utils-aseqnet = "network client/server on ALSA sequencer"
+DESCRIPTION_alsa-utils-alsactl = "saves/restores ALSA-settings in /etc/asound.state"
+DESCRIPTION_alsa-utils-alsaconf = "a bash script that creates ALSA configuration files"
+
+RDEPENDS_alsa-utils-aplay += "alsa-conf"
+RDEPENDS_alsa-utils-amixer += "alsa-conf"
+
+# ALSA can be in kernel
+RRECOMMENDS_alsa-utils += "${ALSA_PACKAGES}"
+ALLOW_EMPTY_alsa-utils = "1"