summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-15 12:03:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-11 17:39:48 +0000
commit519c42d6c32c38d20411afbbd879850d4e6ae3b0 (patch)
tree66a92051c14beb303f92d8d5fbbf6f7a4da671b4 /meta
parent9aa93835d19159ffd7cb212680044fc7f914a68f (diff)
downloadopenembedded-core-519c42d6c32c38d20411afbbd879850d4e6ae3b0.tar.gz
openembedded-core-519c42d6c32c38d20411afbbd879850d4e6ae3b0.tar.bz2
openembedded-core-519c42d6c32c38d20411afbbd879850d4e6ae3b0.zip
libunwind: Fix test case link failure on PowerPC with Altivec
Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/libunwind/libunwind-1.1/Fix-test-case-link-failure-on-PowerPC-systems-with-Altivec.patch28
-rw-r--r--meta/recipes-support/libunwind/libunwind_1.1.bb4
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/libunwind/libunwind-1.1/Fix-test-case-link-failure-on-PowerPC-systems-with-Altivec.patch b/meta/recipes-support/libunwind/libunwind-1.1/Fix-test-case-link-failure-on-PowerPC-systems-with-Altivec.patch
new file mode 100644
index 0000000000..dc0f5c1b47
--- /dev/null
+++ b/meta/recipes-support/libunwind/libunwind-1.1/Fix-test-case-link-failure-on-PowerPC-systems-with-Altivec.patch
@@ -0,0 +1,28 @@
+Fix test case link failure on PowerPC systems with Altivec
+
+Upstream-Status:backport
+
+On systems where the system compiler supports Altivec by default,
+the libunwind Makefile will attempt to build an extra test case
+ppc64-test-altivec. Unfortunately, the link step will fail since
+the Makefile does not actually link against the libunwind library.
+
+Fixed by adding the appropriate LDADD macro.
+
+Signed-off-by: Ulrich Weigand <address@hidden>
+---
+ tests/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 0e30536..9c76628 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -201,3 +201,4 @@ Lia64_test_rbs_LDADD = $(LIBUNWIND_local)
+ Lia64_test_readonly_LDADD = $(LIBUNWIND_local)
+ ia64_test_dyn1_LDADD = $(LIBUNWIND)
+ ia64_test_sig_LDADD = $(LIBUNWIND)
++ppc64_test_altivec_LDADD = $(LIBUNWIND)
+--
+1.8.5
+
diff --git a/meta/recipes-support/libunwind/libunwind_1.1.bb b/meta/recipes-support/libunwind/libunwind_1.1.bb
index bc38e36440..20db132688 100644
--- a/meta/recipes-support/libunwind/libunwind_1.1.bb
+++ b/meta/recipes-support/libunwind/libunwind_1.1.bb
@@ -1,4 +1,8 @@
require libunwind.inc
+SRC_URI += "\
+ file://Fix-test-case-link-failure-on-PowerPC-systems-with-Altivec.patch \
+"
+
SRC_URI[md5sum] = "fb4ea2f6fbbe45bf032cd36e586883ce"
SRC_URI[sha256sum] = "9dfe0fcae2a866de9d3942c66995e4b460230446887dbdab302d41a8aee8d09a"