summaryrefslogtreecommitdiff
path: root/meta/recipes-support/serf/serf_1.3.9.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-11-03 18:35:01 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-15 15:18:48 +0000
commitcb5ae09561d9ab1284f6ae3dc47b58ec647a1734 (patch)
tree62a031b57aa013d50e80b1d12412fd17fe435b7f /meta/recipes-support/serf/serf_1.3.9.bb
parent6b94569d5d8e8bdd575d12e260abf10d3ac11cfd (diff)
downloadopenembedded-core-cb5ae09561d9ab1284f6ae3dc47b58ec647a1734.tar.gz
openembedded-core-cb5ae09561d9ab1284f6ae3dc47b58ec647a1734.tar.bz2
openembedded-core-cb5ae09561d9ab1284f6ae3dc47b58ec647a1734.zip
serf: Update to version 1.3.9
Change SRC_URI to use APACHE_MIRROR to download serf from apache project page and remove UPSTREAM_CHECK_URI. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/serf/serf_1.3.9.bb')
-rw-r--r--meta/recipes-support/serf/serf_1.3.9.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/serf/serf_1.3.9.bb b/meta/recipes-support/serf/serf_1.3.9.bb
new file mode 100644
index 0000000000..2be5a069c4
--- /dev/null
+++ b/meta/recipes-support/serf/serf_1.3.9.bb
@@ -0,0 +1,26 @@
+SUMMARY = "High-Performance Asynchronous HTTP Client Library"
+SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://norpath.patch \
+ file://env.patch"
+
+SRC_URI[md5sum] = "370a6340ff20366ab088012cd13f2b57"
+SRC_URI[sha256sum] = "549c2d21c577a8a9c0450facb5cca809f26591f048e466552240947bdf7a87cc"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+DEPENDS = "python-scons-native openssl apr apr-util util-linux expat"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} PREFIX=${prefix} \
+ CC="${CC}" \
+ APR=`which apr-1-config` APU=`which apu-1-config` \
+ CFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" \
+ OPENSSL="${STAGING_EXECPREFIXDIR}"
+}
+
+do_install() {
+ ${STAGING_BINDIR_NATIVE}/scons PREFIX=${D}${prefix} LIBDIR=${D}${libdir} install
+}
+
+BBCLASSEXTEND = "native"