summaryrefslogtreecommitdiff
path: root/meta/recipes-support/gpgme/gpgme_1.4.3.bb
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-08-08 11:37:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 23:01:35 +0100
commit066eb8fbfd90f1a5af01a8f63adbe0cd2ae8cb5c (patch)
tree37c55a37a8fa3f691525144c72043b4e480253cd /meta/recipes-support/gpgme/gpgme_1.4.3.bb
parente37841faf746895f41627130623196c0bebe0740 (diff)
downloadopenembedded-core-066eb8fbfd90f1a5af01a8f63adbe0cd2ae8cb5c.tar.gz
openembedded-core-066eb8fbfd90f1a5af01a8f63adbe0cd2ae8cb5c.tar.bz2
openembedded-core-066eb8fbfd90f1a5af01a8f63adbe0cd2ae8cb5c.zip
gpgme: Add pkg-config file
A basic gpgme.pc file is installed with gpgme which should allow the library to be found and used using pkg-config rather than gpgme-config. Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gpgme/gpgme_1.4.3.bb')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.4.3.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.4.3.bb b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
index ef08d4f2f4..ca1e5f9344 100644
--- a/meta/recipes-support/gpgme/gpgme_1.4.3.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
@@ -10,7 +10,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
- file://disable_gpgconf_check.patch"
+ file://disable_gpgconf_check.patch \
+ file://gpgme.pc"
SRC_URI[md5sum] = "334e524cffa8af4e2f43ae8afe585672"
SRC_URI[sha256sum] = "2d1cc12411753752d9c5b9037e6fd3fd363517af720154768cc7b46b60120496"
@@ -32,3 +33,8 @@ do_configure_prepend () {
rm -f ${S}/m4/gpg-error.m4
rm -f ${S}/m4/libassuan.m4
}
+
+do_install_append () {
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${WORKDIR}/gpgme.pc ${D}${libdir}/pkgconfig/
+}