summaryrefslogtreecommitdiff
path: root/meta/recipes-support/gdbm/gdbm_1.11.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2014-05-04 16:02:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-06 17:59:06 +0100
commitaaba69d598763831e8b42996154ed87d0db10714 (patch)
tree09dbbb76b4856aae98ed14a8898332f42cde64b3 /meta/recipes-support/gdbm/gdbm_1.11.bb
parent74e377eeb6de606b99ed0ff840922261f4a27abc (diff)
downloadopenembedded-core-aaba69d598763831e8b42996154ed87d0db10714.tar.gz
openembedded-core-aaba69d598763831e8b42996154ed87d0db10714.tar.bz2
openembedded-core-aaba69d598763831e8b42996154ed87d0db10714.zip
gdbm: enable ptest support
Install gdbm test-suite and run it as ptest Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.11.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.11.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.11.bb b/meta/recipes-support/gdbm/gdbm_1.11.bb
index 3d02594881..adf8c5bd38 100644
--- a/meta/recipes-support/gdbm/gdbm_1.11.bb
+++ b/meta/recipes-support/gdbm/gdbm_1.11.bb
@@ -5,12 +5,15 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
-SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
+ file://run-ptest \
+ file://ptest.patch \
+ "
SRC_URI[md5sum] = "72c832680cf0999caedbe5b265c8c1bd"
SRC_URI[sha256sum] = "8d912f44f05d0b15a4a5d96a76f852e905d051bb88022fcdfd98b43be093e3c3"
-inherit autotools gettext texinfo lib_package
+inherit autotools gettext texinfo lib_package ptest
# Needed for dbm python module
EXTRA_OECONF = "-enable-libgdbm-compat"
@@ -28,6 +31,12 @@ do_install_append () {
ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
}
+RDEPENDS_${PN}-ptest += "diffutils"
+
+do_compile_ptest() {
+ oe_runmake -C tests buildtests
+}
+
PACKAGES =+ "${PN}-compat \
"
FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \