summaryrefslogtreecommitdiff
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-11-15 17:01:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-19 16:45:08 +0000
commitc67b5e212244f1bac57e8491c6500656786df3a2 (patch)
tree75a6115614277c7b58bfd9128bcbb33b2e445924 /meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb
parent71f281f40e25bdd3ea052cb673d06c1a250e618f (diff)
downloadopenembedded-core-c67b5e212244f1bac57e8491c6500656786df3a2.tar.gz
openembedded-core-c67b5e212244f1bac57e8491c6500656786df3a2.tar.bz2
openembedded-core-c67b5e212244f1bac57e8491c6500656786df3a2.zip
xkeyboard-config: upgrade to 2.7
A few extra changes: * changed the SRC_URI to the new, valid, one * added dependency of gettext (do_qa_configure detected is needed) * disable runtime dependency checks at configure time Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb
new file mode 100644
index 0000000000..08d03a5ce5
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.7.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Keyboard configuration database for X Window"
+
+DESCRIPTION = "The non-arch keyboard configuration database for X \
+Window. The goal is to provide the consistent, well-structured, \
+frequently released open source of X keyboard configuration data for X \
+Window System implementations. The project is targeted to XKB-based \
+systems."
+
+HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
+
+LICENSE = "MIT & MIT-style"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
+
+SRC_URI="${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
+SRC_URI[md5sum] = "6ad7b43062f123eacf8ff0eb3a4e0678"
+SRC_URI[sha256sum] = "e43478a12fb0fe6757a7bad3a04fd3747ec53e53d5af22a9d9829dfb9aac8321"
+
+SECTION = "x11/libs"
+DEPENDS = "intltool-native xkbcomp-native glib-2.0 virtual/gettext"
+
+PR = "r0"
+
+EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
+
+RDEPENDS_${PN} += "xkbcomp"
+FILES_${PN} += "${datadir}/X11/xkb"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${datadir}/X11/xkb/compiled
+ cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
+}