summaryrefslogtreecommitdiff
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-05-26 16:59:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-30 09:30:33 +0100
commit476d816a49121ba9a3db7720135d3ddaf51e2cc5 (patch)
treeb18f0d5362a00c919985237105a83af66a6a9373 /meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
parent66c3176bfc780a6aa002ff4e6cc12bb06ff0360f (diff)
downloadopenembedded-core-476d816a49121ba9a3db7720135d3ddaf51e2cc5.tar.gz
openembedded-core-476d816a49121ba9a3db7720135d3ddaf51e2cc5.tar.bz2
openembedded-core-476d816a49121ba9a3db7720135d3ddaf51e2cc5.zip
libxcb: upgrade to 1.12
Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.12.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.12.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
new file mode 100644
index 0000000000..62b8bab87f
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
@@ -0,0 +1,36 @@
+SUMMARY = "XCB: The X protocol C binding library"
+DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
+for Xlib featuring a small footprint, latency hiding, direct access to \
+the protocol, improved threading support, and extensibility."
+HOMEPAGE = "http://xcb.freedesktop.org"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
+SECTION = "x11/libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
+
+SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
+ file://xcbincludedir.patch \
+ file://disable-check.patch \
+ file://gcc-mips-pr68302-mips-workaround.patch \
+ "
+SRC_URI[md5sum] = "28e552bd78bc1050b6b26ca1db0e5bb6"
+SRC_URI[sha256sum] = "4adfb1b7c67e99bc9c2ccb110b2f175686576d2f792c8a71b9c8b19014057b5b"
+
+BBCLASSEXTEND = "native nativesdk"
+
+DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp"
+
+PACKAGES_DYNAMIC = "^libxcb-.*"
+
+FILES_${PN} = "${libdir}/libxcb.so.*"
+
+inherit autotools pkgconfig distro_features_check
+
+# The libxau and others requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+REQUIRED_DISTRO_FEATURES_class-native = ""
+
+python populate_packages_prepend () {
+ do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
+}