summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/sudo/sudo_1.8.9p1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-01-13 15:05:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-14 11:33:18 +0000
commit0262bd1fc9507a39b7f313a8a5e85e7001f6bd9f (patch)
tree86f71cf6a5b06e47e503fb599b38053df908d583 /meta/recipes-extended/sudo/sudo_1.8.9p1.bb
parentbf4a2ebce1097394a6ce77511fb9fff319b58858 (diff)
downloadopenembedded-core-0262bd1fc9507a39b7f313a8a5e85e7001f6bd9f.tar.gz
openembedded-core-0262bd1fc9507a39b7f313a8a5e85e7001f6bd9f.tar.bz2
openembedded-core-0262bd1fc9507a39b7f313a8a5e85e7001f6bd9f.zip
sudo: upgrade to 1.8.9p1
Upgrade sudo from 1.8.8 to 1.8.9p1. This patch adds include/queue.h to the LIC_FILES_CHECKSUM because it's specified in the doc/LICENSE file. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/sudo/sudo_1.8.9p1.bb')
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.9p1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-extended/sudo/sudo_1.8.9p1.bb b/meta/recipes-extended/sudo/sudo_1.8.9p1.bb
new file mode 100644
index 0000000000..b3c2086c4e
--- /dev/null
+++ b/meta/recipes-extended/sudo/sudo_1.8.9p1.bb
@@ -0,0 +1,23 @@
+require sudo.inc
+
+SRC_URI = "http://ftp.sudo.ws/sudo/dist/sudo-${PV}.tar.gz \
+ ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
+
+PAM_SRC_URI = "file://sudo.pam"
+
+SRC_URI[md5sum] = "03773c373082843211c96df2c9187146"
+SRC_URI[sha256sum] = "c22089aa1023233bf27808e8f7611b6b4c4fec2d151616179e1898876703cd51"
+
+DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+RDEPENDS_${PN} += " ${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-limits pam-plugin-keyinit', '', d)}"
+
+EXTRA_OECONF += " ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)}"
+
+do_install_append () {
+ if [ "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
+ install -D -m 664 ${WORKDIR}/sudo.pam ${D}/${sysconfdir}/pam.d/sudo
+ fi
+
+ chmod 4111 ${D}${bindir}/sudo
+ chmod 0440 ${D}${sysconfdir}/sudoers
+}