summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/sat-solver/sat-solver_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-06-04 15:06:52 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-15 15:54:18 +0100
commite0800be814c8f8adf8d6682aacea1d3ce9b14c9e (patch)
treed37ed4752f9866758cddee62f468c5a04a6bf4d7 /meta/recipes-extended/sat-solver/sat-solver_git.bb
parent492297fce0b80547d3dac9f611f463c6cc95160b (diff)
downloadopenembedded-core-e0800be814c8f8adf8d6682aacea1d3ce9b14c9e.tar.gz
openembedded-core-e0800be814c8f8adf8d6682aacea1d3ce9b14c9e.tar.bz2
openembedded-core-e0800be814c8f8adf8d6682aacea1d3ce9b14c9e.zip
sat-solver: Fix build on uclibc
futimes is not available on uclibc so use utimes qsort is also not as expected by sat-solver therefore for uclibc we resort to using internal version of qsort Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-extended/sat-solver/sat-solver_git.bb')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
index b0382f6af0..e1054e9e22 100644
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ b/meta/recipes-extended/sat-solver/sat-solver_git.bb
@@ -20,6 +20,7 @@ SRC_URI = "git://github.com/openSUSE/sat-solver.git;protocol=git \
file://sat-solver_core.patch \
file://fix_gcc-4.6.0_compile_issue.patch \
file://0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch \
+ file://futimes.patch \
"
S = "${WORKDIR}/git"
@@ -28,6 +29,8 @@ EXTRA_OECMAKE += "-DRPM5=RPM5 -DOE_CORE=OE_CORE"
EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
+TUNE_CCARGS_append_libc-uclibc = " -DUSE_OWN_QSORT=1 "
+
inherit cmake pkgconfig
RDEPENDS_${PN} = "rpm-libs"