summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/polkit/polkit_0.103.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2011-12-22 12:15:28 +0800
committerSaul Wold <sgw@linux.intel.com>2012-01-02 20:26:22 -0800
commit114c0b6c423863b4ec27b5acbad3930ef1774306 (patch)
treedba9539c61b829d5736eab298703159c27bc42a5 /meta/recipes-extended/polkit/polkit_0.103.bb
parent3570d0b47e7a7ea05964c21da05faf1f09b66e81 (diff)
downloadopenembedded-core-114c0b6c423863b4ec27b5acbad3930ef1774306.tar.gz
openembedded-core-114c0b6c423863b4ec27b5acbad3930ef1774306.tar.bz2
openembedded-core-114c0b6c423863b4ec27b5acbad3930ef1774306.zip
polkit: upgrade to 0.103
This is the patch to upgrade polkit to 0.103. The license is changed because the HTML content is generated by GTK-Doc V1.18 (XML node) rather than GTK-Doc V1.17 (XML node), which causes the change of the tag. Signed-off-by: Shane Wang <shane.wang@intel.com>
Diffstat (limited to 'meta/recipes-extended/polkit/polkit_0.103.bb')
-rw-r--r--meta/recipes-extended/polkit/polkit_0.103.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/polkit/polkit_0.103.bb b/meta/recipes-extended/polkit/polkit_0.103.bb
new file mode 100644
index 0000000000..7f5624228d
--- /dev/null
+++ b/meta/recipes-extended/polkit/polkit_0.103.bb
@@ -0,0 +1,33 @@
+SUMMARY = "PolicyKit Authorization Framework"
+DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
+HOMEPAGE = "http://code.google.com/p/polkit/"
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
+ file://src/polkit/polkit.h;beginline=1;endilne=20;md5=9f797b8912dac8a806be820c14e783f8 \
+ file://docs/polkit/html/license.html;md5=d85a36709a446c10f4ee123f9dda0e38"
+
+SRC_URI = "http://hal.freedesktop.org/releases/polkit-${PV}.tar.gz \
+ file://introspection.patch \
+ ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
+
+SRC_URI[md5sum] = "aaacf2ef18774ea8a825a426a7cfe763"
+SRC_URI[sha256sum] = "36607c8ce576980ee55bd12bab1944f13217eb8e9d04ab56022545861ece3bc5"
+
+PAM_SRC_URI = "file://polkit-1_pam.patch"
+PR = "r0"
+DEPENDS = "libpam expat dbus-glib eggdbus intltool-native"
+RDEPENDS_${PN} = "libpam"
+EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc --disable-introspection"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/${PN}-1/extensions/*.so \
+ ${datadir}/${PN}-1/actions/* \
+ ${datadir}/dbus-1/system-services/*"
+FILES_${PN}-dbg += "${libdir}/${PN}-1/extensions/.debug/*.so"
+FILES_${PN}-dev += "${libdir}/${PN}-1/extensions/*.la "
+
+do_install_append() {
+ rm -f ${D}${libdir}/${PN}-1/extensions/*.a
+}
+