summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
diff options
context:
space:
mode:
authorJesse Zhang <sen.zhang@windriver.com>2013-01-06 09:56:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-08 14:46:12 +0000
commit0a07ec7d13becc7ce87c502e75a006300a7090a5 (patch)
tree2b0b882ede1fa31e115b9871694b0a2d775cdce6 /meta/recipes-extended/ghostscript/ghostscript_9.05.bb
parent7d775b071b902ee0de6391b2c30d36e3003643e1 (diff)
downloadopenembedded-core-0a07ec7d13becc7ce87c502e75a006300a7090a5.tar.gz
openembedded-core-0a07ec7d13becc7ce87c502e75a006300a7090a5.tar.bz2
openembedded-core-0a07ec7d13becc7ce87c502e75a006300a7090a5.zip
ghostscript: fix endianness detection
[ CQID: WIND00394747 ] The original patch removes endianness detection completely, causing lcms to be built against the wrong endian. Instead, pass the correct endian through the recipe using SITEINFO_ENDIANNESS. Signed-off-by: Jesse Zhang <sen.zhang@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.05.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.05.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.05.bb b/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
index 93c503fb74..9ec57120b6 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.05.bb
@@ -15,7 +15,7 @@ SECTION = "console/utils"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c5326026692dbed183f0558f926580f8"
-PR = "r5"
+PR = "r6"
DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
DEPENDS_class-native = ""
@@ -63,6 +63,13 @@ do_configure_prepend () {
if [ -e ${WORKDIR}/objarch.h ]; then
cp ${WORKDIR}/objarch.h obj/arch.h
fi
+ if [ ${SITEINFO_ENDIANNESS} = "le" ]; then
+ export LCMS_BIGENDIAN="0"
+ export LCMS2_BIGENDIAN="0"
+ else
+ export LCMS_BIGENDIAN="1"
+ export LCMS2_BIGENDIAN="1"
+ fi
}
do_configure_append () {