summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/rsync/files/check_libattr.patch
diff options
context:
space:
mode:
authorSergiy Kibrik <sakib@meta.ua>2015-09-17 16:08:02 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 12:01:43 +0000
commit576f63c50badd54b47cdda42a6466bb18984958d (patch)
treec5e8fb48868f71321bd31949e13d666ba58c11b2 /meta/recipes-devtools/rsync/files/check_libattr.patch
parentfb3e73fb2536b718dfce0e7b126f75464b9874aa (diff)
downloadopenembedded-core-576f63c50badd54b47cdda42a6466bb18984958d.tar.gz
openembedded-core-576f63c50badd54b47cdda42a6466bb18984958d.tar.bz2
openembedded-core-576f63c50badd54b47cdda42a6466bb18984958d.zip
rsync: backport libattr checking patch
Add check_libattr.patch to version 3.1.0 recipe, which checks and includes libattr to linker, otherwise rsync may fail to build with linker error below (as -lattr option gets omitted): [..] lib/sysxattrs.o: undefined reference to symbol 'llistxattr@@ATTR_1.0' [..]/lib/libattr.so.1: error adding symbols: DSO missing from command line Signed-off-by: Sergiy Kibrik <sakib@meta.ua> Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta/recipes-devtools/rsync/files/check_libattr.patch')
-rw-r--r--meta/recipes-devtools/rsync/files/check_libattr.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/files/check_libattr.patch b/meta/recipes-devtools/rsync/files/check_libattr.patch
new file mode 100644
index 0000000000..cb159faf76
--- /dev/null
+++ b/meta/recipes-devtools/rsync/files/check_libattr.patch
@@ -0,0 +1,33 @@
+From 677c6e14cc7d5f41371d5616865a5f0cfc0a273f Mon Sep 17 00:00:00 2001
+From: Wayne Davison <wayned@samba.org>
+Date: Mon, 5 May 2014 09:25:13 -0700
+Subject: [PATCH] Check for attr lib.
+
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c7b28c5..8e3703c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1007,7 +1007,7 @@ else
+ *)
+ AC_MSG_RESULT(running tests:)
+ AC_CHECK_LIB(acl,acl_get_file)
+- AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
++ AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
+ AC_TRY_LINK([#include <sys/types.h>
+ #include <sys/acl.h>],
+ [ acl_t acl; int entry_id; acl_entry_t *entry_p; return acl_get_entry( acl, entry_id, entry_p);],
+@@ -1057,6 +1057,7 @@ else
+ AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs])
+ AC_DEFINE(SUPPORT_XATTRS, 1)
+ AC_DEFINE(NO_SYMLINK_USER_XATTRS, 1, [True if symlinks do not support user xattrs])
++ AC_CHECK_LIB(attr,getxattr)
+ ;;
+ darwin*)
+ AC_MSG_RESULT(Using OS X xattrs)
+--
+1.9.1
+