diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-05-14 15:00:26 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-02-02 22:34:32 +0000 |
commit | 185fcfc3286b355394ae89300f22b8cb7aaa43c1 (patch) | |
tree | eee45f4764dc7b1f2c456ed2bee505be46a90d2c /meta/recipes-devtools/python/python3/110-enable-zlib.patch | |
parent | 9a3e4ac4a4eeed64ec80d400130dff3d26daf336 (diff) | |
download | openembedded-core-185fcfc3286b355394ae89300f22b8cb7aaa43c1.tar.gz openembedded-core-185fcfc3286b355394ae89300f22b8cb7aaa43c1.tar.bz2 openembedded-core-185fcfc3286b355394ae89300f22b8cb7aaa43c1.zip |
python3: Add target and native recipes
3.3.3 is latest bugfix release in 3.3 series
License text is changed to reflect year and prev releases
+++ ../Python-3.3.2/LICENSE 2013-05-15 09:32:54.000000000 -0700
@@ -74,7 +74,9 @@
3.2.1 3.2 2011 PSF yes
3.2.2 3.2.1 2011 PSF yes
3.2.3 3.2.2 2012 PSF yes
+ 3.2.4 3.2.3 2013 PSF yes
3.3.0 3.2 2012 PSF yes
+ 3.3.1 3.3.0 2013 PSF yes
Footnotes:
@@ -110,8 +112,8 @@
distribute, and otherwise use Python alone or in any derivative
version,
provided, however, that PSF's License Agreement and PSF's notice of
copyright,
i.e., "Copyright (c) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008,
2009, 2010,
-2011, 2012 Python Software Foundation; All Rights Reserved" are
retained in Python
-alone or in any derivative version prepared by Licensee.
+2011, 2012, 2013 Python Software Foundation; All Rights Reserved" are
retained
+in Python alone or in any derivative version prepared by Licensee.
We use native python in disutils bbclass and this needs
to peek into target sysroot when building plugins in cross
environment. Otherwise anything that inherits distutils3.bbclass
will not build.
Fix host include contamination issue
Let compiler append sysroot to include path if it can
Fix the compiler invocation and linker flags when cross compiling
The details are in patch header. This should fix the QA errors about
host contamination
Add virtual/libintl to dep list
There is use of libintl.h but we dont
express the dependency
Add lzma dependency for python3-misc
Fixes
and from test-dependencies.sh run there is undeterministic lzma
dependency:
WARN: packages/armv5te-oe-linux-gnueabi/python3/python3-misc/latest lost
dependency on liblzma
Fix staging warnings due to duplicate install
WARNING: The recipe python3 is trying to install files into a shared
area when those files already exist. Those files and their manifest
location are:
builds/world/tmp/sysroots/qemux86-64/usr/include/python3.3m/pyconfig.h
builds/world/tmp/sysroots/qemux86-64/usr/lib/libpython3.3m.so.1.0
builds/world/tmp/sysroots/qemux86-64/usr/lib/libpython3.3m.so
builds/world/tmp/sysroots/qemux86-64/usr/lib/python3.3/config/Makefile
Let compiler search includes relative to sysroot
This makes it cross compilable and assumption on hardcoded
paths is fixed.
Errors like below would appear if ncursesw is installed on build host
cc1: warning: include location "/usr/include/ncursesw" is unsafe for
cross-compilation [-Wpoison-system-directories]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Fix linking not happening issue in modules
We need to tweak CONFIGURE_LDFLAGS for python3 instead of LDFLAGS
directly
Add second compile stage which uses original makefile
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3/110-enable-zlib.patch')
-rw-r--r-- | meta/recipes-devtools/python/python3/110-enable-zlib.patch | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/110-enable-zlib.patch b/meta/recipes-devtools/python/python3/110-enable-zlib.patch new file mode 100644 index 0000000000..fb92a19163 --- /dev/null +++ b/meta/recipes-devtools/python/python3/110-enable-zlib.patch @@ -0,0 +1,21 @@ +Enable zlib in python + +-Khem + +Upstream-Status: Inappropriate [OE-Specific] + +--- + Modules/Setup.dist | 2 +- + 1 file changed, 1 insertion(+), 1 deletion(-) + +--- a/Modules/Setup.dist ++++ b/Modules/Setup.dist +@@ -354,7 +354,7 @@ _symtable symtablemodule.c + # Andrew Kuchling's zlib module. + # This require zlib 1.1.3 (or later). + # See http://www.gzip.org/zlib/ +-#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz ++zlib zlibmodule.c -lz + + # Interface to the Expat XML parser + # |