summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-11-10 23:34:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:30:56 +0000
commit701ec1977ced1bb08461e6de98b4f63d21cba8a6 (patch)
tree714f6f1f0a829cd52b6e0667b736ce8775be6109 /meta/recipes-devtools/python/python3/04-default-is-optimized.patch
parent91165c1b68e49e5d5392068df3412ebb7b0e969b (diff)
downloadopenembedded-core-701ec1977ced1bb08461e6de98b4f63d21cba8a6.tar.gz
openembedded-core-701ec1977ced1bb08461e6de98b4f63d21cba8a6.tar.bz2
openembedded-core-701ec1977ced1bb08461e6de98b4f63d21cba8a6.zip
python3: Upgrade from 3.4.3 to 3.5
python3-native_3.4.3.bb -> python3-native_3.5.0.bb: - changed version - changed cheksum - no license change, just dates python3_3.4.3.bb -> python3_3.5.0.bb: - changed version - changed cheksum - no license change, just dates New: - use_packed_importlib.patch: Fixes importlib on cross-compile environments Rebased: - Manifest - 000-cross-compile.patch - 020-dont-compile-python-files.patch - 04-default-is-optimized.patch - python-3.3-multilib.patch - distutils3-base.bbclass - distutils3-native-base.bbclass - python3native.bbclass Upstream: - makerace.patch Misc: - pip2 is handled as default on major distros, modified python3-pip to leave /usr/bin/pip available for pip2 - Fixed importing pip3 from python3 interpreter Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3/04-default-is-optimized.patch')
-rw-r--r--meta/recipes-devtools/python/python3/04-default-is-optimized.patch38
1 files changed, 19 insertions, 19 deletions
diff --git a/meta/recipes-devtools/python/python3/04-default-is-optimized.patch b/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
index 3b8f264a58..4b8a7e56bc 100644
--- a/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
+++ b/meta/recipes-devtools/python/python3/04-default-is-optimized.patch
@@ -12,24 +12,11 @@ Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
Rebased for 3.4.2 02/2015
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-Index: Python-3.4.2/Python/compile.c
+Index: Python-3.5.0/Modules/main.c
===================================================================
---- Python-3.4.2.orig/Python/compile.c
-+++ Python-3.4.2/Python/compile.c
-@@ -30,7 +30,7 @@
- #include "symtable.h"
- #include "opcode.h"
-
--int Py_OptimizeFlag = 0;
-+int Py_OptimizeFlag = 1;
-
- #define DEFAULT_BLOCK_SIZE 16
- #define DEFAULT_BLOCKS 8
-Index: Python-3.4.2/Modules/main.c
-===================================================================
---- Python-3.4.2.orig/Modules/main.c
-+++ Python-3.4.2/Modules/main.c
-@@ -38,7 +38,7 @@ static wchar_t **orig_argv;
+--- Python-3.5.0.orig/Modules/main.c
++++ Python-3.5.0/Modules/main.c
+@@ -37,7 +37,7 @@ static wchar_t **orig_argv;
static int orig_argc;
/* command line options */
@@ -38,7 +25,7 @@ Index: Python-3.4.2/Modules/main.c
#define PROGRAM_OPTS BASE_OPTS
-@@ -64,6 +64,7 @@ static char *usage_2 = "\
+@@ -63,6 +63,7 @@ static char *usage_2 = "\
-m mod : run library module as a script (terminates option list)\n\
-O : optimize generated bytecode slightly; also PYTHONOPTIMIZE=x\n\
-OO : remove doc-strings in addition to the -O optimizations\n\
@@ -46,7 +33,7 @@ Index: Python-3.4.2/Modules/main.c
-q : don't print version and copyright messages on interactive startup\n\
-s : don't add user site directory to sys.path; also PYTHONNOUSERSITE\n\
-S : don't imply 'import site' on initialization\n\
-@@ -418,8 +419,8 @@ Py_Main(int argc, wchar_t **argv)
+@@ -419,8 +420,8 @@ Py_Main(int argc, wchar_t **argv)
/* case 'J': reserved for Jython */
@@ -57,3 +44,16 @@ Index: Python-3.4.2/Modules/main.c
break;
case 'B':
+Index: Python-3.5.0/Python/pylifecycle.c
+===================================================================
+--- Python-3.5.0.orig/Python/pylifecycle.c
++++ Python-3.5.0/Python/pylifecycle.c
+@@ -80,7 +80,7 @@ int Py_VerboseFlag; /* Needed by import.
+ int Py_QuietFlag; /* Needed by sysmodule.c */
+ int Py_InteractiveFlag; /* Needed by Py_FdIsInteractive() below */
+ int Py_InspectFlag; /* Needed to determine whether to exit at SystemExit */
+-int Py_OptimizeFlag = 0; /* Needed by compile.c */
++int Py_OptimizeFlag = 1; /* Needed by compile.c */
+ int Py_NoSiteFlag; /* Suppress 'import site' */
+ int Py_BytesWarningFlag; /* Warn on str(bytes) and str(buffer) */
+ int Py_UseClassExceptionsFlag = 1; /* Needed by bltinmodule.c: deprecated */