summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-06-06 14:37:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-08 11:11:22 +0100
commitc26156898ca83c96fea100ced9bc1f3d5b974bda (patch)
treece67fe69b90ce3b9b3297fdfd51ec5acc76a5952 /meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch
parentee054e12f6d4c4cbda66ebbc7d09ecad964a84d1 (diff)
downloadopenembedded-core-c26156898ca83c96fea100ced9bc1f3d5b974bda.tar.gz
openembedded-core-c26156898ca83c96fea100ced9bc1f3d5b974bda.tar.bz2
openembedded-core-c26156898ca83c96fea100ced9bc1f3d5b974bda.zip
gcc-8: Add recipes for 8.1 release
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch b/meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..fe0fb7d531
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-8.1/0011-fortran-cross-compile-hack.patch
@@ -0,0 +1,46 @@
+From 71cba188d47b6ae9d9b87261eb4bc9eb68ae355d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 29 Mar 2013 09:20:01 +0400
+Subject: [PATCH 11/39] fortran cross-compile hack.
+
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+directory.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [embedded specific]
+---
+ libgfortran/configure | 2 +-
+ libgfortran/configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index 91fce8fecd0..6747f86eb98 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -12883,7 +12883,7 @@ esac
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${ac_fc_srcext-f}
+ ac_compile='$FC -c $FCFLAGS $ac_fcflags_srcext conftest.$ac_ext >&5'
+ ac_link='$FC -o conftest$ac_exeext $FCFLAGS $LDFLAGS $ac_fcflags_srcext conftest.$ac_ext $LIBS >&5'
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index bf6d3634dda..9dbe43cc616 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -250,7 +250,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets
+--
+2.17.0
+