summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-07-24 13:11:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-27 10:36:28 +0100
commit2a212e56a814e5dc8a8bae4974b91109ed0486ef (patch)
tree474fadc9377c83df36013d68050c58816cd3b4b7 /meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch
parentef2a842d06b3a9ee6036af06247c7c022f8c720d (diff)
downloadopenembedded-core-2a212e56a814e5dc8a8bae4974b91109ed0486ef.tar.gz
openembedded-core-2a212e56a814e5dc8a8bae4974b91109ed0486ef.tar.bz2
openembedded-core-2a212e56a814e5dc8a8bae4974b91109ed0486ef.zip
gcc5: Upgrade from 5.1 to 5.2
This is second bugfix release in gcc5 series All backported patches are dropped no other patches needed any rework Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch b/meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..da73392cae
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-5.2/0018-fortran-cross-compile-hack.patch
@@ -0,0 +1,46 @@
+From 95506b44c9ef4725fef52fa864d3d3fcf931e443 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 29 Mar 2013 09:20:01 +0400
+Subject: [PATCH 18/35] fortran cross-compile hack.
+
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+directory.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [embedded specific]
+---
+ libgfortran/configure | 2 +-
+ libgfortran/configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index e1592f7..76d19b3 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -12747,7 +12747,7 @@ esac
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${ac_fc_srcext-f}
+ ac_compile='$FC -c $FCFLAGS $ac_fcflags_srcext conftest.$ac_ext >&5'
+ ac_link='$FC -o conftest$ac_exeext $FCFLAGS $LDFLAGS $ac_fcflags_srcext conftest.$ac_ext $LIBS >&5'
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 35a8b39..6a0d8a9 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -240,7 +240,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets
+--
+2.1.4
+