summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-02-23 19:14:58 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 14:48:49 +0100
commit3f8fee75e598ad0994acc5da0a612e6eca4f35f6 (patch)
treeecb67530d31f8c65aad0f37aca9052b0bed0da8e /meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch
parent7159dad19f8cfd3e7e95523da63e91370744da7f (diff)
downloadopenembedded-core-3f8fee75e598ad0994acc5da0a612e6eca4f35f6.tar.gz
openembedded-core-3f8fee75e598ad0994acc5da0a612e6eca4f35f6.tar.bz2
openembedded-core-3f8fee75e598ad0994acc5da0a612e6eca4f35f6.zip
gcc-4.7: Add recipes
Add new recipes for gcc-4_7-branch right now gcc 4.7.0 is latest release from this branch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch b/meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..2773b42cca
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-4.7/fortran-cross-compile-hack.patch
@@ -0,0 +1,32 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+Index: gcc-4_7-branch/libgfortran/configure
+===================================================================
+--- gcc-4_7-branch.orig/libgfortran/configure 2012-04-10 10:17:24.055330044 -0700
++++ gcc-4_7-branch/libgfortran/configure 2012-04-10 10:42:26.159402591 -0700
+@@ -12689,7 +12689,7 @@
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${ac_fc_srcext-f}
+ ac_compile='$FC -c $FCFLAGS $ac_fcflags_srcext conftest.$ac_ext >&5'
+ ac_link='$FC -o conftest$ac_exeext $FCFLAGS $LDFLAGS $ac_fcflags_srcext conftest.$ac_ext $LIBS >&5'
+Index: gcc-4_7-branch/libgfortran/configure.ac
+===================================================================
+--- gcc-4_7-branch.orig/libgfortran/configure.ac 2012-04-10 10:17:24.063330046 -0700
++++ gcc-4_7-branch/libgfortran/configure.ac 2012-04-10 10:42:26.159402591 -0700
+@@ -227,7 +227,7 @@
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets