summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-07-22 16:58:32 +0300
committerSaul Wold <sgw@linux.intel.com>2013-07-25 23:44:27 -0700
commitd79521cf1777276a5e85d59f9e078f4d6d9603aa (patch)
treecb961158a51079f665887f1a2e0900970d9345ab /meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff
parent025ee772f4ec21abef1fd89c4a36dbc02c9143a9 (diff)
downloadopenembedded-core-d79521cf1777276a5e85d59f9e078f4d6d9603aa.tar.gz
openembedded-core-d79521cf1777276a5e85d59f9e078f4d6d9603aa.tar.bz2
openembedded-core-d79521cf1777276a5e85d59f9e078f4d6d9603aa.zip
elfutils: fix backends' Makefile.am
The mips, m68k and parisc backend libraries were not generated. This patch fixes that. [YOCTO #4849] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff12
1 files changed, 9 insertions, 3 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff b/meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff
index e9b5c402eb..79a8f0e437 100644
--- a/meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff
+++ b/meta/recipes-devtools/elfutils/elfutils-0.155/m68k_backend.diff
@@ -219,7 +219,7 @@ Index: elfutils-0.155/libelf/elf.h
===================================================================
--- elfutils-0.155.orig/libelf/elf.h
+++ elfutils-0.155/libelf/elf.h
-@@ -1126,6 +1126,9 @@ typedef struct
+@@ -1126,6 +1126,9 @@
#define R_68K_GLOB_DAT 20 /* Create GOT entry */
#define R_68K_JMP_SLOT 21 /* Create PLT entry */
#define R_68K_RELATIVE 22 /* Adjust by program base */
@@ -233,7 +233,7 @@ Index: elfutils-0.155/backends/Makefile.am
===================================================================
--- elfutils-0.155.orig/backends/Makefile.am
+++ elfutils-0.155/backends/Makefile.am
-@@ -32,7 +32,7 @@ INCLUDES += -I$(top_srcdir)/libebl -I$(t
+@@ -32,12 +32,12 @@
-I$(top_srcdir)/libelf -I$(top_srcdir)/libdw
@@ -242,7 +242,13 @@ Index: elfutils-0.155/backends/Makefile.am
libebl_pic = libebl_i386_pic.a libebl_sh_pic.a libebl_x86_64_pic.a \
libebl_ia64_pic.a libebl_alpha_pic.a libebl_arm_pic.a \
libebl_sparc_pic.a libebl_ppc_pic.a libebl_ppc64_pic.a \
-@@ -111,6 +111,10 @@ mips_SRCS = mips_init.c mips_symbol.c mi
+ libebl_s390_pic.a libebl_tilegx_pic.a libebl_parisc_pic.a \
+- libebl_mips_pic.a
++ libebl_mips_pic.a libebl_m68k_pic.a
+ noinst_LIBRARIES = $(libebl_pic)
+ noinst_DATA = $(libebl_pic:_pic.a=.so)
+
+@@ -112,6 +112,10 @@
libebl_mips_pic_a_SOURCES = $(mips_SRCS)
am_libebl_mips_pic_a_OBJECTS = $(mips_SRCS:.c=.os)