summaryrefslogtreecommitdiff
path: root/meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-04-15 16:11:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:46:24 +0100
commite28e11930a22a4e89075e7e026e58c081f984ddf (patch)
tree0c05686ae9df2fffd8dc2179e78e356c7e2b87c1 /meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch
parentcd13726f1eb1f77f55cf202830d6bf13b47b0860 (diff)
downloadopenembedded-core-e28e11930a22a4e89075e7e026e58c081f984ddf.tar.gz
openembedded-core-e28e11930a22a4e89075e7e026e58c081f984ddf.tar.bz2
openembedded-core-e28e11930a22a4e89075e7e026e58c081f984ddf.zip
openssl: upgrade to version 0.9.8r
[YOCTO #979] from 0.9.8p fixes CVE-2010-4180, CVE-2010-4252, CVE-2010-0014 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch b/meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch
new file mode 100644
index 0000000000..bfddfc8a74
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-0.9.8r/parallel-make-fix.patch
@@ -0,0 +1,20 @@
+Upstream-Status: Pending
+
+fix the parallel build regarding shared libraries.
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/Makefile.org b/Makefile.org
+index 2fb0309..8bec3d0 100644
+--- a/Makefile.org
++++ b/Makefile.org
+@@ -352,6 +352,9 @@ all_testapps: build_libs build_testapps
+ build_testapps:
+ @dir=crypto; target=testapps; $(BUILD_ONE_CMD)
+
++libcrypto.a: build_crypto
++libssl.a: build_ssl
++
+ build_shared: $(SHARED_LIBS)
+ libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \