summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-01-14 04:17:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-17 11:32:17 +0000
commitfd0a8923638217dfa0a61ee63f2013229429808c (patch)
treeac4d455cd38c850815df147141ca2628e98da0ce /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
parent2dbc788bc3988532f0932e8e51e24ba702c28f6a (diff)
downloadopenembedded-core-fd0a8923638217dfa0a61ee63f2013229429808c.tar.gz
openembedded-core-fd0a8923638217dfa0a61ee63f2013229429808c.tar.bz2
openembedded-core-fd0a8923638217dfa0a61ee63f2013229429808c.zip
u-boot: Update to 2016.01 release
Upgrade U-Boot to latest version and drop upstreamed patches. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Otavio Salvador <otavio@ossystems.com.br> Cc: Ross Burton <ross.burton@intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
new file mode 100644
index 0000000000..5d163a8af4
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.01.bb
@@ -0,0 +1,32 @@
+SUMMARY = "U-Boot bootloader image creation tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"
+SECTION = "bootloader"
+
+DEPENDS = "openssl"
+
+# This revision corresponds to the tag "v2016.01"
+# We use the revision in order to avoid having to fetch it from the
+# repo during parse
+SRCREV = "fa85e826c16b9ce1ad302a57e9c4b24db0d8b930"
+
+PV = "v2016.01+git${SRCPV}"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+
+do_compile () {
+ oe_runmake sandbox_defconfig
+ oe_runmake cross_tools NO_SDL=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+
+BBCLASSEXTEND = "native nativesdk"