summaryrefslogtreecommitdiff
path: root/meta/packages/xorg-xserver
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-09-22 13:33:19 +0000
committerRobert Bragg <bob@openedhand.com>2008-09-22 13:33:19 +0000
commit3de4627417e62595ce4349cb3a13c9180f8e6bfd (patch)
tree37c5f48d49ce9702fb164ca4fe47433f59cd838a /meta/packages/xorg-xserver
parent9b6a24b65d840d8b207a9dfdc69e61b0c5c9ef07 (diff)
downloadopenembedded-core-3de4627417e62595ce4349cb3a13c9180f8e6bfd.tar.gz
openembedded-core-3de4627417e62595ce4349cb3a13c9180f8e6bfd.tar.bz2
openembedded-core-3de4627417e62595ce4349cb3a13c9180f8e6bfd.zip
Adds recipes to support building X servers based on the xfree86 DDX instead
of kdrive and building mesa. It's a big commit and it's still rather rough around the edges, but there is a desire to get this in early so people can review the work and help polish the changes. Some of the notable bits: • DRI support in mesa and the X server. (configured in machine conf via MACHINE_DRI_MODULES variable) • XCB backend for xlib • A fairly lite X server build with lots of legacy modules disabled. I'm sure there is plenty of other fairly low hanging fruit if we want to put more effort into reducing the size of the xserver build. Currently the server build comes in @ ~2.3MB vs a kdrive fbdev server build @ ~1MB. E.g xaa could be made conditional to save ~320K. Of course the kdrive server doesn't include glx stuff, which is a pretty big chunk. Also thanks to hrw, since I nabbed a some patches from him for this, and RP, for various bits of Poky style advice. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5205 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-xserver')
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-common.inc53
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite.inc31
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch13
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf73
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.5.0.bb7
-rw-r--r--meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb10
6 files changed, 187 insertions, 0 deletions
diff --git a/meta/packages/xorg-xserver/xserver-xf86-common.inc b/meta/packages/xorg-xserver/xserver-xf86-common.inc
new file mode 100644
index 0000000000..ea296e001d
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-common.inc
@@ -0,0 +1,53 @@
+DESCRIPTION = "The X.Org X server"
+HOMEPAGE = "http://www.x.org"
+SECTION = "x11/base"
+LICENSE = "MIT-X"
+
+# xf86-*-* packages depend on an X server built with the xfree86 DDX
+# so we have a virtual to represent that:
+PROVIDES = "virtual/xserver-xf86"
+
+# Other packages tend to just care that there is *an* X server:
+PROVIDES += "virtual/xserver"
+
+XORG_PN = "xorg-server"
+SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
+ file://xorg.conf"
+
+S = "${WORKDIR}/${XORG_PN}-${PV}"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ "${PN}-utils"
+
+FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
+FILES_${PN} = "${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/xorg/modules/*.so /etc/X11 "
+FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
+
+FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
+ ${libdir}/xorg/modules/*/.debug \
+ ${libdir}/xorg/modules/*/*/.debug \
+ "
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+
+# xorg-server.m4 contains a macro used by the xf86-*-* drivers to check for
+# server extensions. The problem is that it modifies CFLAGS during the drivers
+# ./configure with -I`pkg-config --variable=sdkdir xorg-server` and the sdkdir
+# variable doesn't point into the staging area and so causes
+# "CROSS COMPILE Badness" warnings.
+do_configure_prepend () {
+ sed -i "s|\`pkg-config --variable=sdkdir xorg-server\`|${STAGING_DIR}/${HOST_SYS}/\`pkg-config --variable=sdkdir xorg-server\`|" xorg-server.m4
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append () {
+ install -d ${D}/${sysconfdir}/X11
+# install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+ ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
+
+}
+
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite.inc b/meta/packages/xorg-xserver/xserver-xf86-dri-lite.inc
new file mode 100644
index 0000000000..1cc7bdde4e
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite.inc
@@ -0,0 +1,31 @@
+require xserver-xf86-common.inc
+
+PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86rushproto xf86vidmodeproto xf86bigfontproto compositeproto recordproto resourceproto videoproto scrnsaverproto evieext trapproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto glproto xf86driproto dri2proto"
+
+LIB_DEPS = "pixman mesa-dri libxfont xtrans libxau libxext libxdmcp libdrm libxkbfile libpciaccess openssl"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+RDEPENDS = "hal xorg-minimal-fonts"
+
+FILES_${PN} += "${bindir}/Xorg "
+
+EXTRA_OECONF += "--disable-cfb \
+ --disable-afb \
+ --disable-mfb \
+ --disable-dga \
+ --disable-xinerama \
+ --disable-xf86misc \
+ --disable-xorgcfg \
+ --disable-dmx \
+ --disable-xnest \
+ --disable-xvfb \
+ --enable-composite \
+ --enable-dri \
+ --enable-glx-tls \
+ --sysconfdir=/etc/X11 \
+ --localstatedir=/var \
+ --with-fontdir=/usr/share/fonts/X11 \
+ --with-xkb-output=/var/lib/xkb \
+ ac_cv_file__usr_share_sgml_X11_defs_ent=no"
+
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch
new file mode 100644
index 0000000000..a62a767f23
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/drmfix.patch
@@ -0,0 +1,13 @@
+Index: xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am
+===================================================================
+--- xorg-server-1.4.orig/hw/xfree86/os-support/linux/Makefile.am 2007-08-23 21:04:53.000000000 +0200
++++ xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am 2008-03-13 18:27:23.000000000 +0100
+@@ -41,7 +41,7 @@
+
+ AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(DIX_CFLAGS) $(XORG_CFLAGS) $(PLATFORM_DEFINES)
+
+-INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) -I/usr/include/drm # FIXME this last part is crack
++INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) $(LIBDRM_CFLAGS)
+
+ # FIXME: These need to be added to the build
+ LNX_EXTRA_SRCS = \
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf
new file mode 100644
index 0000000000..e3ffbe6ed3
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf
@@ -0,0 +1,73 @@
+
+Section "Files"
+EndSection
+
+Section "InputDevice"
+ Identifier "Synaptics Touchpad"
+ Driver "synaptics"
+ Option "SendCoreEvents" "true"
+ Option "Device" "/dev/psaux"
+ Option "Protocol" "auto-dev"
+ Option "HorizEdgeScroll" "0"
+EndSection
+
+Section "InputDevice"
+ Driver "wacom"
+ Identifier "stylus"
+ Option "Device" "/dev/input/wacom"
+ Option "Type" "stylus"
+ Option "ForceDevice" "ISDV4" # Tablet PC ONLY
+EndSection
+
+Section "InputDevice"
+ Driver "wacom"
+ Identifier "eraser"
+ Option "Device" "/dev/input/wacom"
+ Option "Type" "eraser"
+ Option "ForceDevice" "ISDV4" # Tablet PC ONLY
+EndSection
+
+Section "InputDevice"
+ Driver "wacom"
+ Identifier "cursor"
+ Option "Device" "/dev/input/wacom"
+ Option "Type" "cursor"
+ Option "ForceDevice" "ISDV4" # Tablet PC ONLY
+EndSection
+
+Section "Device"
+ Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
+ Driver "intel"
+ BusID "PCI:0:2:0"
+ Option "AccelMethod" "EXA"
+EndSection
+
+Section "Monitor"
+ Identifier "Generic Monitor"
+ Option "DPMS"
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
+ Monitor "Generic Monitor"
+ DefaultDepth 24
+ SubSection "Display"
+ Modes "1024x768" "720x400" "640x480"
+ Virtual 3000 2048
+ EndSubSection
+EndSection
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+ InputDevice "Generic Keyboard"
+ InputDevice "Configured Mouse"
+
+# Uncomment if you have a wacom tablet
+# InputDevice "stylus" "SendCoreEvents"
+# InputDevice "cursor" "SendCoreEvents"
+# InputDevice "eraser" "SendCoreEvents"
+ InputDevice "Synaptics Touchpad"
+EndSection
+
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.5.0.bb b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.5.0.bb
new file mode 100644
index 0000000000..9f4cb8ec75
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.5.0.bb
@@ -0,0 +1,7 @@
+require xserver-xf86-dri-lite.inc
+
+PE = "1"
+PR = "r1"
+
+SRC_URI += "file://drmfix.patch;patch=1"
+
diff --git a/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb
new file mode 100644
index 0000000000..47be75fdb6
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb
@@ -0,0 +1,10 @@
+require xserver-xf86-dri-lite.inc
+
+PE = "1"
+PR = "r1"
+PV = "1.5.0+git${SRCREV}"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "git://anongit.freedesktop.org/git/xorg/xserver;protocol=git "
+