summaryrefslogtreecommitdiff
path: root/meta/packages/wbxml
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-26 19:02:44 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:07:04 +0000
commite380b48602db316c7d12d328192eadc52e5be861 (patch)
tree78d1c6d7742c79216b01fb0b739adea44c85dc51 /meta/packages/wbxml
parentf9f549d06fd787f93c9c0af607683d0521fcd827 (diff)
downloadopenembedded-core-e380b48602db316c7d12d328192eadc52e5be861.tar.gz
openembedded-core-e380b48602db316c7d12d328192eadc52e5be861.tar.bz2
openembedded-core-e380b48602db316c7d12d328192eadc52e5be861.zip
classes/autotools_stage.bbclass: Add autotools_stage class to simplify recipes using standard autotools
Diffstat (limited to 'meta/packages/wbxml')
-rw-r--r--meta/packages/wbxml/wbxml2_0.9.2.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta/packages/wbxml/wbxml2_0.9.2.bb b/meta/packages/wbxml/wbxml2_0.9.2.bb
index 85b533044d..14c3f6acc3 100644
--- a/meta/packages/wbxml/wbxml2_0.9.2.bb
+++ b/meta/packages/wbxml/wbxml2_0.9.2.bb
@@ -6,17 +6,13 @@ DEPENDS = "libxml2 sed-native expat"
SRC_URI = "${SOURCEFORGE_MIRROR}/wbxmllib/${P}.tar.gz \
file://no-doc-install.patch;patch=1"
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
do_configure_append() {
sed -i s:-I/usr/include::g Makefile
sed -i s:-I/usr/include::g */Makefile
}
-do_stage() {
- autotools_stage_all
-}
-
PACKAGES += "${PN}-tools"
FILES_${PN}-tools = "${bindir}"