summaryrefslogtreecommitdiff
path: root/meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-06 05:07:49 -0700
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 22:05:20 -0700
commite18aba581c7f3f8518b8a9a850b6fe1eabc285ff (patch)
tree364264738a43168c79ba49402b0a7535e0a24ad8 /meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch
parent936a73eae5fd5732c9dc5ae2a47d6196f7f69c0a (diff)
downloadopenembedded-core-e18aba581c7f3f8518b8a9a850b6fe1eabc285ff.tar.gz
openembedded-core-e18aba581c7f3f8518b8a9a850b6fe1eabc285ff.tar.bz2
openembedded-core-e18aba581c7f3f8518b8a9a850b6fe1eabc285ff.zip
python: upgrade from 2.6.2 to 2.6.5
python-native: upgrade from 2.6.1 to 2.6.5 Also removed these older version files: python_2.5.2 python-native_2.5.1 Rebased the patches to the newer code. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch')
-rw-r--r--meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch b/meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch
new file mode 100644
index 0000000000..2559e3a0e4
--- /dev/null
+++ b/meta/packages/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch
@@ -0,0 +1,20 @@
+# $(exec_prefix) points to the wrong directory, when installing
+# a cross-build. @bindir@ and @libdir@ works better and doesn't
+# affect the native build.
+# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
+
+Index: Python-2.6.1/Makefile.pre.in
+===================================================================
+--- Python-2.6.1.orig/Makefile.pre.in
++++ Python-2.6.1/Makefile.pre.in
+@@ -86,8 +86,8 @@ exec_prefix= @exec_prefix@
+ datarootdir= @datarootdir@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include