summaryrefslogtreecommitdiff
path: root/meta/packages/mozilla-headless/mozilla-headless_hg.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-20 01:22:17 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-20 01:22:17 +0100
commit6c5d81946aac4f94ca42fdc02542420cb38ed756 (patch)
tree753a0196a5d55d453929286cb9256a13d6774d7f /meta/packages/mozilla-headless/mozilla-headless_hg.bb
parent25185d5bb2cc100c606d332482ba2243f0aab3c9 (diff)
downloadopenembedded-core-6c5d81946aac4f94ca42fdc02542420cb38ed756.tar.gz
openembedded-core-6c5d81946aac4f94ca42fdc02542420cb38ed756.tar.bz2
openembedded-core-6c5d81946aac4f94ca42fdc02542420cb38ed756.zip
mozilla-headless: Hardcode compiler options for now
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/mozilla-headless/mozilla-headless_hg.bb')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless_hg.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless_hg.bb b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
index e8351703c7..44a829c7a3 100644
--- a/meta/packages/mozilla-headless/mozilla-headless_hg.bb
+++ b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
@@ -3,10 +3,12 @@ FIXEDREV = "f4348fd85697"
SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=${FIXEDREV};module=offscreen \
file://configurefix.patch;patch=1 \
+ file://0001-Adds-initial-Gtk-clipboard-support-to-moz-headless.patch;patch=1 \
+ file://mozilla-jemalloc.patch;patch=1 \
file://jsautocfg.h \
file://mozconfig"
PV = "0.0+hg-1.0+${FIXEDREV}"
-PR = "r0"
+PR = "r1"
S = "${WORKDIR}/offscreen"
@@ -16,6 +18,14 @@ FILES_${PN} += "${libdir}/xulrunner-1.9.2a1pre"
FILES_${PN}-dev += "${libdir}/xulrunner-devel-1.9.2a1pre"
FILES_${PN}-dbg += "${libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/.debug"
+TARGET_CC_ARCH = ""
+
+CFLAGS = "${TARGET_CFLAGS}"
+TARGET_CFLAGS = "-Os -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=core2 -msse3 -mtune=generic -mfpmath=sse -fasynchronous-unwind-tables"
+
+LDFLAGS = "${TARGET_LDFLAGS}"
+TARGET_LDFLAGS = "-Wl,-rpath,${libdir}/xulrunner-1.9.2a1pre"
+
inherit autotools_stage mozilla
acpaths = "-I ${S}/build/autoconf "
@@ -41,8 +51,8 @@ do_install_append () {
echo ${libdir}/xulrunner-1.9.2a1pre/ > ${D}${sysconfdir}/ld.so.conf.d/mozilla-headless
}
-EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless \
- --enable-pango --disable-optimize --disable-debug --disable-tests \
+EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --with-pthreads \
+ --enable-pango --enable-optimize --disable-debug --disable-tests \
--disable-printing --disable-crashreporter --disable-accessibility \
--disable-javaxpcom --enable-plugins --enable-system-sqlite --disable-necko-wifi"
@@ -55,5 +65,6 @@ do_stage_append () {
ln -fs ${STAGING_DIR_HOST}${layout_datadir}/xulrunner-1.9.2a1pre/unstable/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/idl
ln -fs ${STAGING_DIR_HOST}${layout_includedir}/xulrunner-1.9.2a1pre/unstable/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/include
ln -fs ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/sdk/lib/ ${STAGING_DIR_HOST}${layout_libdir}/xulrunner-devel-1.9.2a1pre/lib
+ install -m 755 ${S}/dist/host/bin/host_xpidl ${STAGING_BINDIR_NATIVE}/xpidl
}