summaryrefslogtreecommitdiff
path: root/meta/packages/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-21 12:13:42 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-21 12:13:42 +0000
commitb3b8d9ed94ea6cc713a4a0831bc3d5693c44429e (patch)
tree76436ec7d406c25bc9234916779cc682d99ec257 /meta/packages/hostap/hostap-conf_1.0.bb
parentf86905db21ac92fef46889e705f69e0aba6af8b8 (diff)
downloadopenembedded-core-b3b8d9ed94ea6cc713a4a0831bc3d5693c44429e.tar.gz
openembedded-core-b3b8d9ed94ea6cc713a4a0831bc3d5693c44429e.tar.bz2
openembedded-core-b3b8d9ed94ea6cc713a4a0831bc3d5693c44429e.zip
hostap: Sync with OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@918 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/hostap/hostap-conf_1.0.bb')
-rw-r--r--meta/packages/hostap/hostap-conf_1.0.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/meta/packages/hostap/hostap-conf_1.0.bb b/meta/packages/hostap/hostap-conf_1.0.bb
index 1b0edf19cb..b95b3dd2c4 100644
--- a/meta/packages/hostap/hostap-conf_1.0.bb
+++ b/meta/packages/hostap/hostap-conf_1.0.bb
@@ -3,13 +3,32 @@ SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "GPL"
PACKAGE_ARCH = "all"
-PR = "r4"
+PR = "r8"
SRC_URI = "file://hostap_cs.conf \
+ file://hostap_cs.modalias \
file://hostap_cs.conf-upstream"
+do_compile() {
+}
+
do_install() {
install -d ${D}${sysconfdir}/pcmcia
+ install -d ${D}${sysconfdir}/modutils
+
install -m 0644 ${WORKDIR}/hostap_cs.conf-upstream ${D}${sysconfdir}/pcmcia/hostap_cs.conf
cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
+
+ install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
}