summaryrefslogtreecommitdiff
path: root/meta/packages/fakeroot/fakeroot_1.9.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-03 18:33:03 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-03 18:33:03 +0000
commit66b6014139d4e4c0b0c2e21c6a08cc31c31652b0 (patch)
tree03813b44a50e84ff3998b5610cbc5350437d4ac1 /meta/packages/fakeroot/fakeroot_1.9.4.bb
parent8bc4105ddff851fc0e2c716d677b52236f6c3209 (diff)
downloadopenembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.tar.gz
openembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.tar.bz2
openembedded-core-66b6014139d4e4c0b0c2e21c6a08cc31c31652b0.zip
fakeroot: Clean up and convert to BBCLASSEXTEND
Diffstat (limited to 'meta/packages/fakeroot/fakeroot_1.9.4.bb')
-rw-r--r--meta/packages/fakeroot/fakeroot_1.9.4.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/meta/packages/fakeroot/fakeroot_1.9.4.bb b/meta/packages/fakeroot/fakeroot_1.9.4.bb
index aaf696d79d..04219519ed 100644
--- a/meta/packages/fakeroot/fakeroot_1.9.4.bb
+++ b/meta/packages/fakeroot/fakeroot_1.9.4.bb
@@ -4,15 +4,22 @@ SECTION = "base"
LICENSE = "GPL"
# fakeroot needs getopt which is provided by the util-linux package
RDEPENDS = "util-linux"
-PR = "r1"
+PR = "r2"
SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
file://configure-libtool.patch;patch=1"
-inherit autotools
+inherit autotools_stage
-do_stage() {
+do_stage_append() {
install -d ${STAGING_INCDIR}/fakeroot
install -m 644 *.h ${STAGING_INCDIR}/fakeroot
- autotools_stage_all
}
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.inherits_class("native", d) and bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp ', d)
+}
+
+BBCLASSEXTEND = "native" \ No newline at end of file