summaryrefslogtreecommitdiff
path: root/meta/packages/dbus/dbus-native_1.0.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-21 14:20:37 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-21 14:20:37 +0000
commit0405bf5645e53ae375fd54e8f95b140b374421e0 (patch)
tree6d0fe0c651f550cb5977eb2f617a7a2941c5230c /meta/packages/dbus/dbus-native_1.0.1.bb
parent902bcfa157f48a012a8c3135d45d3f9479e63136 (diff)
downloadopenembedded-core-0405bf5645e53ae375fd54e8f95b140b374421e0.tar.gz
openembedded-core-0405bf5645e53ae375fd54e8f95b140b374421e0.tar.bz2
openembedded-core-0405bf5645e53ae375fd54e8f95b140b374421e0.zip
Add dbus+dbus-native 1.01, dbus-glib+dbus-glib-native 0.72 from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@929 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/dbus/dbus-native_1.0.1.bb')
-rw-r--r--meta/packages/dbus/dbus-native_1.0.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus-native_1.0.1.bb b/meta/packages/dbus/dbus-native_1.0.1.bb
new file mode 100644
index 0000000000..7e5e4df9dd
--- /dev/null
+++ b/meta/packages/dbus/dbus-native_1.0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "message bus system for applications to talk to one another"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "GPL"
+SECTION = "base"
+
+PR = "r0"
+
+DEPENDS = "glib-2.0-native libxml2-native expat-native"
+
+DEFAULT_PREFERENCE = "-1"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://cross.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig gettext native
+
+S = "${WORKDIR}/dbus-${PV}"
+
+EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \
+ --disable-checks --disable-xml-docs --disable-doxygen-docs \
+ --with-xml=expat --without-x"
+
+do_stage () {
+ oe_runmake install
+ autotools_stage_all
+
+ # for dbus-glib-native introspection generation
+ install -d ${STAGING_DATADIR}/dbus
+ install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
+}