summaryrefslogtreecommitdiff
path: root/meta/packages/dbus/dbus-glib_0.76.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-05 17:04:39 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-05 17:04:39 +0000
commit0d8a8c893226ec11bdfb51466199e1d748875338 (patch)
treea68fba4ce96cb15879041dd8e096ecb3b73db937 /meta/packages/dbus/dbus-glib_0.76.bb
parenteae7eb5bd559c1f4ae843820f2d4105066b3cc45 (diff)
downloadopenembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.tar.gz
openembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.tar.bz2
openembedded-core-0d8a8c893226ec11bdfb51466199e1d748875338.zip
dbus-native: Generate the dbus-bus-introspect.xml so dbus-glib recipes don't have to find the dbus source. Pass the location of the file to dbus-glib* with the --with-introspect and drop the now unneeded patch
Diffstat (limited to 'meta/packages/dbus/dbus-glib_0.76.bb')
-rw-r--r--meta/packages/dbus/dbus-glib_0.76.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/packages/dbus/dbus-glib_0.76.bb b/meta/packages/dbus/dbus-glib_0.76.bb
index 0a34c738c3..c69420e460 100644
--- a/meta/packages/dbus/dbus-glib_0.76.bb
+++ b/meta/packages/dbus/dbus-glib_0.76.bb
@@ -1,21 +1,21 @@
SECTION = "base"
-PR = "r0"
+PR = "r1"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
DESCRIPTION = "message bus system for applications to talk to one another"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
- file://no-examples.patch;patch=1 \
- file://no-introspect.patch;patch=1"
+ file://no-examples.patch;patch=1"
inherit autotools pkgconfig gettext
+EXTRA_OECONF = "--with-introspect=${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml"
+
FILES_${PN} = "${libdir}/lib*.so.*"
FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
do_configure_prepend() {
- install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml ${S}/tools/
install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-glib-bindings.h ${S}/tools/
}