summaryrefslogtreecommitdiff
path: root/meta/packages/automake/automake_1.10.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-31 18:56:40 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-02 11:21:51 +0000
commitba2b8cb172e39cf305fcefbcc42d1875552af344 (patch)
treea2afb0d2228ad44a79a2ece792e44527042547b7 /meta/packages/automake/automake_1.10.2.bb
parent4bb83f1e22e7164d38c4d2e2d80ea6d971904f23 (diff)
downloadopenembedded-core-ba2b8cb172e39cf305fcefbcc42d1875552af344.tar.gz
openembedded-core-ba2b8cb172e39cf305fcefbcc42d1875552af344.tar.bz2
openembedded-core-ba2b8cb172e39cf305fcefbcc42d1875552af344.zip
automake: 1.10.1 -> 1.10.2
Diffstat (limited to 'meta/packages/automake/automake_1.10.2.bb')
-rw-r--r--meta/packages/automake/automake_1.10.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/automake/automake_1.10.2.bb b/meta/packages/automake/automake_1.10.2.bb
new file mode 100644
index 0000000000..4c54d069ca
--- /dev/null
+++ b/meta/packages/automake/automake_1.10.2.bb
@@ -0,0 +1,38 @@
+require automake.inc
+
+RDEPENDS_automake += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-dynaloader \
+ perl-module-errno \
+ perl-module-exporter-heavy \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-glob \
+ perl-module-file-spec-unix \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-vars "
+
+SRC_URI += "file://path_prog_fixes.patch;patch=1"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.10 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.10 ${D}${datadir}/automake
+ fi
+}