summaryrefslogtreecommitdiff
path: root/meta/packages/apt
diff options
context:
space:
mode:
authorChris Larson <kergoth@openedhand.com>2006-09-19 09:04:09 +0000
committerChris Larson <kergoth@openedhand.com>2006-09-19 09:04:09 +0000
commit4fa2d11bb1fdb58ff426114169583672fc3d65b8 (patch)
tree0bd4952bbe057c3dc219be7e371a6a9d496c6535 /meta/packages/apt
parent04f695333350e31fa87b7822c17a073af73fcd84 (diff)
downloadopenembedded-core-4fa2d11bb1fdb58ff426114169583672fc3d65b8.tar.gz
openembedded-core-4fa2d11bb1fdb58ff426114169583672fc3d65b8.tar.bz2
openembedded-core-4fa2d11bb1fdb58ff426114169583672fc3d65b8.zip
Sync up.. all the deb/dpkg changes which I have locally are now in svn.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@728 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r--meta/packages/apt/apt-0.6.45exp2/noconfigure.patch35
-rw-r--r--meta/packages/apt/apt-native.inc56
-rw-r--r--meta/packages/apt/apt-native_0.6.45exp2.bb3
-rw-r--r--meta/packages/apt/files/apt.conf16
4 files changed, 82 insertions, 28 deletions
diff --git a/meta/packages/apt/apt-0.6.45exp2/noconfigure.patch b/meta/packages/apt/apt-0.6.45exp2/noconfigure.patch
new file mode 100644
index 0000000000..682a96da24
--- /dev/null
+++ b/meta/packages/apt/apt-0.6.45exp2/noconfigure.patch
@@ -0,0 +1,35 @@
+---
+ apt-pkg/packagemanager.cc | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc
++++ apt-0.6.45exp2/apt-pkg/packagemanager.cc
+@@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI
+
+ List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States);
+
++#if 0
+ // Perform immedate configuration of the package.
+ if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true)
+ if (SmartConfigure(Pkg) == false)
+ return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name());
++#endif
+
+ return true;
+ }
+@@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag
+ DoneSomething = true;
+ }
+
++#if 0
+ // Final run through the configure phase
+ if (ConfigureAll() == false)
+ return Failed;
+@@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag
+ return Failed;
+ }
+ }
++#endif
+
+ return Completed;
+ }
diff --git a/meta/packages/apt/apt-native.inc b/meta/packages/apt/apt-native.inc
index 4ace9e94bb..de9426bf70 100644
--- a/meta/packages/apt/apt-native.inc
+++ b/meta/packages/apt/apt-native.inc
@@ -19,39 +19,43 @@ python do_stage_config () {
data = bb.data.expand(data, d)
- outpath = bb.data.expand('${STAGING_DIR}/${sysconfdir}/apt.conf', d)
+ outdir = os.path.join(bb.data.getVar('sysconfdir', d, 1), 'apt')
+ if not os.path.exists(outdir):
+ os.makedirs(outdir)
+ outpath = os.path.join(outdir, 'apt.conf')
+
outfile = file(outpath, 'w')
outfile.write(data)
outfile.close()
}
do_stage_base () {
- install -d ${STAGING_BINDIR}
- install -m 0755 bin/apt-cdrom ${STAGING_BINDIR}/
- install -m 0755 bin/apt-get ${STAGING_BINDIR}/
- install -m 0755 bin/apt-config ${STAGING_BINDIR}/
- install -m 0755 bin/apt-cache ${STAGING_BINDIR}/
+ install -d ${bindir}
+ install -m 0755 bin/apt-cdrom ${bindir}/
+ install -m 0755 bin/apt-get ${bindir}/
+ install -m 0755 bin/apt-config ${bindir}/
+ install -m 0755 bin/apt-cache ${bindir}/
- install -m 0755 bin/apt-sortpkgs ${STAGING_BINDIR}/
- install -m 0755 bin/apt-extracttemplates ${STAGING_BINDIR}/
+ install -m 0755 bin/apt-sortpkgs ${bindir}/
+ install -m 0755 bin/apt-extracttemplates ${bindir}/
eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
- oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${STAGING_LIBDIR}/
- ln -sf libapt-pkg$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-pkg.so
- oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${STAGING_LIBDIR}/
- ln -sf libapt-inst$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-inst.so
-
- install -d ${STAGING_LIBDIR}/apt/methods
- install -m 0755 bin/methods/* ${STAGING_LIBDIR}/apt/methods/
-
- install -d ${STAGING_LIBDIR}/dpkg/methods/apt
- install -m 0644 dselect/desc.apt ${STAGING_LIBDIR}/dpkg/methods/apt/
- install -m 0644 dselect/names ${STAGING_LIBDIR}/dpkg/methods/apt/
- install -m 0755 dselect/install ${STAGING_LIBDIR}/dpkg/methods/apt/
- install -m 0755 dselect/setup ${STAGING_LIBDIR}/dpkg/methods/apt/
- install -m 0755 dselect/update ${STAGING_LIBDIR}/dpkg/methods/apt/
-
- install -d ${STAGING_DIR}${sysconfdir}/apt
- install -d ${STAGING_DIR}${localstatedir}/lib/apt/lists/partial
- install -d ${STAGING_DIR}${localstatedir}/cache/apt/archives/partial
+ oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${libdir}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so ${libdir}/libapt-pkg.so
+ oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${libdir}/
+ ln -sf libapt-inst$GLIBC_VER-6.so ${libdir}/libapt-inst.so
+
+ install -d ${libdir}/apt/methods
+ install -m 0755 bin/methods/* ${libdir}/apt/methods/
+
+ install -d ${libdir}/dpkg/methods/apt
+ install -m 0644 dselect/desc.apt ${libdir}/dpkg/methods/apt/
+ install -m 0644 dselect/names ${libdir}/dpkg/methods/apt/
+ install -m 0755 dselect/install ${libdir}/dpkg/methods/apt/
+ install -m 0755 dselect/setup ${libdir}/dpkg/methods/apt/
+ install -m 0755 dselect/update ${libdir}/dpkg/methods/apt/
+
+ install -d ${sysconfdir}/apt
+ install -d ${localstatedir}/lib/apt/lists/partial
+ install -d ${localstatedir}/cache/apt/archives/partial
}
diff --git a/meta/packages/apt/apt-native_0.6.45exp2.bb b/meta/packages/apt/apt-native_0.6.45exp2.bb
index 32f19e8e4c..43f73889f7 100644
--- a/meta/packages/apt/apt-native_0.6.45exp2.bb
+++ b/meta/packages/apt/apt-native_0.6.45exp2.bb
@@ -1,3 +1,4 @@
require apt-native.inc
-SRC_URI += "file://nodoc.patch;patch=1"
+SRC_URI += "file://nodoc.patch;patch=1 \
+ file://noconfigure.patch;patch=1"
diff --git a/meta/packages/apt/files/apt.conf b/meta/packages/apt/files/apt.conf
index 944233c347..37785871db 100644
--- a/meta/packages/apt/files/apt.conf
+++ b/meta/packages/apt/files/apt.conf
@@ -3,7 +3,7 @@ Dir "${STAGING_DIR}/"
State "var/lib/apt/"
{
Lists "lists/";
- status "${IMAGE_ROOTFS}/${localstatedir}/lib/dpkg/status";
+ status "${IMAGE_ROOTFS}/var/dpkg/status";
};
Cache "var/cache/apt/"
{
@@ -22,3 +22,17 @@ Dir "${STAGING_DIR}/"
apt-cache "apt-cache";
};
};
+
+APT
+{
+ Immediate-Configure "false";
+ Architecture "i586";
+ Get
+ {
+ Assume-Yes "true";
+ Force-Yes "true"
+ };
+};
+
+DPkg::Options {"--root=${IMAGE_ROOTFS}";"--admindir=${IMAGE_ROOTFS}/var/dpkg";"--force-all";"--no-debsig"};
+};