summaryrefslogtreecommitdiff
path: root/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 16:26:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 16:26:54 +0000
commit43aab47cfc79563a192b49f0ca40a86d04e93f8f (patch)
tree496118724ae8bcef5f2d646d4039802b758f2bb8 /meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
parent0a968eeb415dc0aa829b1457ec8f404926ea6780 (diff)
downloadopenembedded-core-43aab47cfc79563a192b49f0ca40a86d04e93f8f.tar.gz
openembedded-core-43aab47cfc79563a192b49f0ca40a86d04e93f8f.tar.bz2
openembedded-core-43aab47cfc79563a192b49f0ca40a86d04e93f8f.zip
gsmd2: taken from OE, cleaned, fixed deps/building, improved packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4933 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
new file mode 100644
index 0000000000..410ac36e2f
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GSM 07.10 muxer userspace daemon"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
+AUTHOR = "M. Dietrich"
+SECTION = "console/network"
+DEPENDS = "dbus dbus-glib"
+LICENSE = "GPL"
+PV = "0.9.1+gitr${SRCREV}"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+# install init script for people who want to manually
+# start/stop it, but don't add runlevels.
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"