summaryrefslogtreecommitdiff
path: root/meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2008-11-03 19:14:00 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2008-11-03 19:14:00 +0100
commitbebb376e62f94fec5caa1abb6141a6e6728ae95f (patch)
tree2e1cefeb324a5d0b30fe90c3619098098052e130 /meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch
parent7b5d03d08e737dd3637072f60259af5b093b7f70 (diff)
downloadopenembedded-core-bebb376e62f94fec5caa1abb6141a6e6728ae95f.tar.gz
openembedded-core-bebb376e62f94fec5caa1abb6141a6e6728ae95f.tar.bz2
openembedded-core-bebb376e62f94fec5caa1abb6141a6e6728ae95f.zip
sreadahead: Initial commit
Super readahead is an improved readahead tool.
Diffstat (limited to 'meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch')
-rw-r--r--meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch b/meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch
new file mode 100644
index 0000000000..d0ece663b5
--- /dev/null
+++ b/meta-moblin/packages/sreadahead/sreadahead-0.02/sreadahead-0.02-make.patch
@@ -0,0 +1,27 @@
+diff -Nrup sreadahead-0.02.orig/Makefile sreadahead-0.02/Makefile
+--- sreadahead-0.02.orig/Makefile 2008-09-23 22:36:24.000000000 +0200
++++ sreadahead-0.02/Makefile 2008-09-26 07:43:19.000000000 +0200
+@@ -1,11 +1,18 @@
+-all: generate_filelist sreadahead
++CFLAGS=-Os -g -Wall
++PROGS=generate_filelist sreadahead
++
++all: $(PROGS)
+
+
+ generate_filelist: readahead.h filelist.c Makefile
+- gcc -Os -g -Wall -W filelist.c -o generate_filelist
++ $(CC) $(CFLAGS) -W filelist.c -o generate_filelist
+
+ sreadahead: readahead.h readahead.c Makefile
+- gcc -Os -g -Wall -lpthread -W readahead.c -o sreadahead
++ $(CC) $(CFLAGS) -lpthread -W readahead.c -o sreadahead
+
+ clean:
+- rm -f *~ sreadahead generate_filelist
+\ No newline at end of file
++ rm -f *~ sreadahead generate_filelist
++
++install: all
++ mkdir -p $(DESTDIR)/sbin
++ install -p -m 755 $(PROGS) $(DESTDIR)/sbin