summaryrefslogtreecommitdiff
path: root/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-03 05:18:43 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-03 05:18:43 +0000
commit27f3b8da5da091243683e63a1506438577184d0e (patch)
treeaeaf53396b4ddf54a7768f8d261aa231a2b6c37b /meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
parent4d10f010f4cf2049c43583afbd5fd85ac6df91a8 (diff)
downloadopenembedded-core-27f3b8da5da091243683e63a1506438577184d0e.tar.gz
openembedded-core-27f3b8da5da091243683e63a1506438577184d0e.tar.bz2
openembedded-core-27f3b8da5da091243683e63a1506438577184d0e.zip
python: upgraded to 2.5.2 (merged from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4163 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch')
-rw-r--r--meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch b/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
deleted file mode 100644
index 93bd343381..0000000000
--- a/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: Python-2.5.1/setup.py
-===================================================================
---- Python-2.5.1.orig/setup.py
-+++ Python-2.5.1/setup.py
-@@ -1227,7 +1227,7 @@ class PyBuildExt(build_ext):
- dotversion = dotversion[:-1] + '.' + dotversion[-1]
- tcl_include_sub = []
- tk_include_sub = []
-- for dir in inc_dirs:
-+ for dir in [os.getenv("STAGING_INCDIR")]:
- tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
- tk_include_sub += [dir + os.sep + "tk" + dotversion]
- tk_include_sub += tcl_include_sub
-@@ -1246,22 +1246,6 @@ class PyBuildExt(build_ext):
- if dir not in include_dirs:
- include_dirs.append(dir)
-
-- # Check for various platform-specific directories
-- if platform == 'sunos5':
-- include_dirs.append('/usr/openwin/include')
-- added_lib_dirs.append('/usr/openwin/lib')
-- elif os.path.exists('/usr/X11R6/include'):
-- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/lib64')
-- added_lib_dirs.append('/usr/X11R6/lib')
-- elif os.path.exists('/usr/X11R5/include'):
-- include_dirs.append('/usr/X11R5/include')
-- added_lib_dirs.append('/usr/X11R5/lib')
-- else:
-- # Assume default location for X11
-- include_dirs.append('/usr/X11/include')
-- added_lib_dirs.append('/usr/X11/lib')
--
- # If Cygwin, then verify that X is installed before proceeding
- if platform == 'cygwin':
- x11_inc = find_file('X11/Xlib.h', [], include_dirs)