summaryrefslogtreecommitdiff
path: root/meta-extras/packages/python/python-2.5.1/autohell.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-15 13:55:06 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-15 13:55:06 +0000
commit3cfbc3b20b524748ec7253d6dfdc0c5eb17836cc (patch)
treed6731c1df8707972687bac18db0336599cfffe66 /meta-extras/packages/python/python-2.5.1/autohell.patch
parenteaafa55d861b0a31e62895845730e778a0253ec9 (diff)
downloadopenembedded-core-3cfbc3b20b524748ec7253d6dfdc0c5eb17836cc.tar.gz
openembedded-core-3cfbc3b20b524748ec7253d6dfdc0c5eb17836cc.tar.bz2
openembedded-core-3cfbc3b20b524748ec7253d6dfdc0c5eb17836cc.zip
python: update to 2.5.1 from OE (without tcl/tk deps)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3176 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python/python-2.5.1/autohell.patch')
-rw-r--r--meta-extras/packages/python/python-2.5.1/autohell.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-2.5.1/autohell.patch b/meta-extras/packages/python/python-2.5.1/autohell.patch
new file mode 100644
index 0000000000..e2d63145be
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/autohell.patch
@@ -0,0 +1,49 @@
+#
+# FIXME: Don't simply rip this test out... add getting it from cache
+#
+Index: Python-2.5.1/configure.in
+===================================================================
+--- Python-2.5.1.orig/configure.in
++++ Python-2.5.1/configure.in
+@@ -3367,41 +3367,6 @@ else
+ AC_MSG_RESULT(no)
+ fi
+
+-AC_MSG_CHECKING(for %zd printf() format support)
+-AC_TRY_RUN([#include <stdio.h>
+-#include <stddef.h>
+-#include <string.h>
+-
+-int main()
+-{
+- char buffer[256];
+-
+-#ifdef HAVE_SSIZE_T
+-typedef ssize_t Py_ssize_t;
+-#elif SIZEOF_VOID_P == SIZEOF_LONG
+-typedef long Py_ssize_t;
+-#else
+-typedef int Py_ssize_t;
+-#endif
+-
+- if(sprintf(buffer, "%zd", (size_t)123) < 0)
+- return 1;
+-
+- if (strcmp(buffer, "123"))
+- return 1;
+-
+- if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0)
+- return 1;
+-
+- if (strcmp(buffer, "-123"))
+- return 1;
+-
+- return 0;
+-}],
+-[AC_MSG_RESULT(yes)
+- AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])],
+- AC_MSG_RESULT(no))
+-
+ AC_CHECK_TYPE(socklen_t,,
+ AC_DEFINE(socklen_t,int,
+ Define to `int' if <sys/socket.h> does not define.),[