summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2012-05-30 17:08:28 +0800
committerScott Garman <scott.a.garman@intel.com>2012-06-12 13:29:30 -0700
commitdf83a9480ba7b2fd2bcc0a92932d51434d7795a0 (patch)
tree21392eec0b5c41ba833240bb3244c35ad924d173
parent3788f9bcb36cca90ca8cf650c9d33f5485e3087b (diff)
downloadopenembedded-core-df83a9480ba7b2fd2bcc0a92932d51434d7795a0.tar.gz
openembedded-core-df83a9480ba7b2fd2bcc0a92932d51434d7795a0.tar.bz2
openembedded-core-df83a9480ba7b2fd2bcc0a92932d51434d7795a0.zip
webkit-gtk: Use glib as unicode backend to avoid browser crash
webkit-gtk depends on ICU for the unicode, but ICU is not safe when build and target system owns different endian. ICU's community is not responsive to make a patch for this, so glib is used as work around here. [YOCTO #1570] got fixed Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_svn.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_svn.bb b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
index 7db573d056..9381486e20 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_svn.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_svn.bb
@@ -10,12 +10,13 @@ LIC_FILES_CHKSUM = "file://Source/WebCore/rendering/RenderApplet.h;endline=22;md
DEPENDS = "zlib enchant gnome-keyring libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3"
DEPENDS += " ${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
DEPENDS_darwin8 = "curl icu libxml2 cairo libxslt libidn gnutls gtk+ gstreamer flex-native gperf-native perl-native-runtime sqlite3"
+DEPENDS_append_qemuppc += "pango"
SRCREV_FORMAT = "source"
SRCREV = "101488"
PV = "1.7.2+svnr${SRCPV}"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=Source;proto=http;name=source \
@@ -47,6 +48,13 @@ EXTRA_OECONF = "\
UNICODE_CFLAGS=-D_REENTRANT \
"
+#default unicode backend icu breaks in cross-compile when target and host owns different endian type
+EXTRA_OECONF_append_qemuppc += "--with-unicode-backend=glib"
+
+CPPFLAGS_append_qemuppc += "-I${STAGING_INCDIR}/pango-1.0 \
+ -I${STAGING_LIBDIR}/glib-2.0/include \
+ -I${STAGING_INCDIR}/glib-2.0"
+
EXTRA_AUTORECONF = " -I Source/autotools "