summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-12-01 16:26:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-11 17:39:52 +0000
commitbb4270020852ea19e40635d306e0bf7de6ec225a (patch)
tree4704be4044e6d77d10132ceae495111ec5d8b39a
parent8e2f9d9e25c7db9a0912219445bfdf8af3a63002 (diff)
downloadopenembedded-core-bb4270020852ea19e40635d306e0bf7de6ec225a.tar.gz
openembedded-core-bb4270020852ea19e40635d306e0bf7de6ec225a.tar.bz2
openembedded-core-bb4270020852ea19e40635d306e0bf7de6ec225a.zip
python: ensure all of Python is installed in nativesdk
If any part of Python gets installed in a SDK, we need to ensure that all of Python gets installed to avoid replacing python in the environment with a minimal package set. [ YOCTO #6735 ] (From OE-Core rev: e36ff98a7a4da478bb886f61005cd72a0b5a9c0e) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/python/python_2.7.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.3.bb b/meta/recipes-devtools/python/python_2.7.3.bb
index 2547ea41c8..bada39bcfe 100644
--- a/meta/recipes-devtools/python/python_2.7.3.bb
+++ b/meta/recipes-devtools/python/python_2.7.3.bb
@@ -160,6 +160,7 @@ require python-${PYTHON_MAJMIN}-manifest.inc
# manual dependency additions
RPROVIDES_${PN}-core = "${PN}"
RRECOMMENDS_${PN}-core = "${PN}-readline"
+RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python-modules"
RRECOMMENDS_${PN}-crypt = "openssl"
RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"