summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-19 17:16:09 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-19 17:16:09 +0000
commit88213327d85e2c8f8df9a64c0c0cc9bfd42268f7 (patch)
treede3c56efc1d68872d5236177fa2e3775849cd528
parent2bee9ce9ef24d703d153b36b92b8f14dc02f018f (diff)
downloadopenembedded-core-88213327d85e2c8f8df9a64c0c0cc9bfd42268f7.tar.gz
openembedded-core-88213327d85e2c8f8df9a64c0c0cc9bfd42268f7.tar.bz2
openembedded-core-88213327d85e2c8f8df9a64c0c0cc9bfd42268f7.zip
netbase: Drop options file and options handling code, its replaced by sysctl.conf
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5078 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/netbase/netbase/init56
-rw-r--r--meta/packages/netbase/netbase/options3
-rw-r--r--meta/packages/netbase/netbase_4.21.bb6
3 files changed, 2 insertions, 63 deletions
diff --git a/meta/packages/netbase/netbase/init b/meta/packages/netbase/netbase/init
index e40578cfdf..8a67e1cef2 100644
--- a/meta/packages/netbase/netbase/init
+++ b/meta/packages/netbase/netbase/init
@@ -15,64 +15,8 @@ if ! [ -x /sbin/ifup ]; then
exit 0
fi
-spoofprotect_rp_filter () {
- # This is the best method: turn on Source Address Verification and get
- # spoof protection on all current and future interfaces.
-
- if [ -e /proc/sys/net/ipv4/conf/all/rp_filter ]; then
- for f in /proc/sys/net/ipv4/conf/*; do
- [ -e $f/rp_filter ] && echo 1 > $f/rp_filter
- done
- return 0
- else
- return 1
- fi
-}
-
-spoofprotect () {
- echo -n "Setting up IP spoofing protection: "
- if spoofprotect_rp_filter; then
- echo "rp_filter."
- else
- echo "FAILED."
- fi
-}
-
-ip_forward () {
- if [ -e /proc/sys/net/ipv4/ip_forward ]; then
- echo -n "Enabling packet forwarding... "
- echo 1 > /proc/sys/net/ipv4/ip_forward
- echo "done."
- fi
-}
-
-syncookies () {
- if [ -e /proc/sys/net/ipv4/tcp_syncookies ]; then
- echo -n "Enabling TCP/IP SYN cookies... "
- echo 1 > /proc/sys/net/ipv4/tcp_syncookies
- echo "done."
- fi
-}
-
-doopt () {
- optname=$1
- default=$2
- opt=`grep "^$optname=" /etc/network/options`
- if [ -z "$opt" ]; then
- opt="$optname=$default"
- fi
- optval=${opt#$optname=}
- if [ "$optval" = "yes" ]; then
- eval $optname
- fi
-}
-
case "$1" in
start)
- doopt spoofprotect yes
- doopt syncookies no
- doopt ip_forward no
-
echo -n "Configuring network interfaces... "
ifup -a
echo "done."
diff --git a/meta/packages/netbase/netbase/options b/meta/packages/netbase/netbase/options
deleted file mode 100644
index 2000189d19..0000000000
--- a/meta/packages/netbase/netbase/options
+++ /dev/null
@@ -1,3 +0,0 @@
-ip_forward=no
-spoofprotect=yes
-syncookies=no
diff --git a/meta/packages/netbase/netbase_4.21.bb b/meta/packages/netbase/netbase_4.21.bb
index f6ea116a0a..17c6bb9f3d 100644
--- a/meta/packages/netbase/netbase_4.21.bb
+++ b/meta/packages/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPL"
-PR = "r21"
+PR = "r22"
inherit update-rc.d
@@ -15,7 +15,6 @@ INITSCRIPT_PARAMS_openmn = "start 85 1 2 3 4 5 . stop 85 0 6 1 ."
INITSCRIPT_PARAMS_slugos = "start 42 S 0 6 ."
SRC_URI = "${DEBIAN_MIRROR}/main/n/netbase/netbase_${PV}.tar.gz \
- file://options \
file://init \
file://hosts \
file://interfaces"
@@ -28,7 +27,6 @@ do_install () {
${D}${sysconfdir}/network/if-up.d \
${D}${sysconfdir}/network/if-down.d \
${D}${sysconfdir}/network/if-post-down.d
- install -m 0644 ${WORKDIR}/options ${D}${sysconfdir}/network/options
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts
install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
@@ -48,7 +46,7 @@ do_install () {
esac
}
-CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts ${sysconfdir}/network/interfaces"
+CONFFILES_${PN} = "${sysconfdir}/hosts ${sysconfdir}/network/interfaces"
PACKAGE_ARCH_omap-3430sdp = "${MACHINE_ARCH}"
PACKAGE_ARCH_omap-3430ldp = "${MACHINE_ARCH}"