summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2014-11-03 17:43:00 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 10:17:13 +0000
commit857661e7d55ac73c7c360f49a0103f2a5cd8a310 (patch)
tree9468845a557301c74262e5bf8a7b4427c814dcfb
parent5ab3d737a9961725b97204a99167f4e0df2fa005 (diff)
downloadopenembedded-core-857661e7d55ac73c7c360f49a0103f2a5cd8a310.tar.gz
openembedded-core-857661e7d55ac73c7c360f49a0103f2a5cd8a310.tar.bz2
openembedded-core-857661e7d55ac73c7c360f49a0103f2a5cd8a310.zip
perl: Fix bug when installs SDK in custom directory
Add site_perl and vendor_perl directories in create_wrapper this fix bug when searching for libraries in these directories. [YOCTO #6890] (From OE-Core rev: ea2584213e2e852157ec2490c84cc6c03feb4b40) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index e594c5c7cf..ec01765ea3 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -221,7 +221,7 @@ do_install() {
do_install_append_class-nativesdk () {
create_wrapper ${D}${bindir}/perl \
- PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/${PV}'
+ PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/site_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/vendor_perl/${PV}'
}
PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"