summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe PRIOUZEAU <christophe.priouzeau@st.com>2018-11-22 12:13:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 20:12:10 +0000
commit6a1c020008d334b56b94399a61ad1dc3a4817b36 (patch)
treebc66909a0bddab029080a396133c767a8bb63d91
parentef91e281bb1e24a26f3179fd9f511714a0d4c746 (diff)
downloadopenembedded-core-6a1c020008d334b56b94399a61ad1dc3a4817b36.tar.gz
openembedded-core-6a1c020008d334b56b94399a61ad1dc3a4817b36.tar.bz2
openembedded-core-6a1c020008d334b56b94399a61ad1dc3a4817b36.zip
openssl: correct bad path on package preprocess
In case of SDK generation, /usr/bin/ path are not correct and must be replaced by ${bindir}. (From OE-Core rev: 0fa7d99444763192914e798d8bc9dba1d9cdae42) Signed-off-by: Christophe Priouzeau <christophe.priouzeau@st.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb b/meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb
index 4325940701..42f9bcfdcc 100644
--- a/meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb
+++ b/meta/recipes-connectivity/openssl/openssl10_1.0.2p.bb
@@ -354,8 +354,8 @@ openssl_package_preprocess () {
for file in `find ${PKGD} -name *.h -o -name *.pc -o -name *.so`; do
rm $file
done
- rm ${PKGD}/usr/bin/openssl
- rm ${PKGD}/usr/bin/c_rehash
- rmdir ${PKGD}/usr/bin
+ rm ${PKGD}${bindir}/openssl
+ rm ${PKGD}${bindir}/c_rehash
+ rmdir ${PKGD}${bindir}
}