summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGernot Hillier <gernot.hillier@siemens.com>2017-04-26 12:57:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-28 11:32:21 +0100
commit004332fc15358c4088686babffd3b038798f420a (patch)
treeb3f5dbc8f5d940dd787eac05cf8e097b8e82a449
parentc93691b3d8b300d5cdeb1c9f1a052f7c32bba23b (diff)
downloadopenembedded-core-master-next2.tar.gz
openembedded-core-master-next2.tar.bz2
openembedded-core-master-next2.zip
tcf-agent: enable default target debugging featuresmaster-next2
A number of features were disabled in OE due to historic problems on ARM. In tcf-agent 1.4, they compile cleanly on all architectures besides mips and libc-musl. These features are required for target debugging with Eclipse Neon, CDT and TCF plugins - for example used by Xilinx Vivado SDK 2016.4. For MIPS and libc-musl, at least re-enable SERVICE_Symbols and SERVICE_LineNumbers which compile cleanly. Signed-off-by: Gernot Hillier <gernot.hillier@siemens.com> Signed-off-by: Tim Offermann <tim.offermann@siemens.com> Acked-by: Eugene Tarassov <eugene.tarassov@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
index cd0081ac16..1dad825fda 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -35,11 +35,16 @@ MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
-# They don't build on ARM and we don't need them actually.
-CFLAGS += "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+# These features don't compile on mips and libc-musl
+CFLAGS_mips_append = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
-DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
- -DSERVICE_StackTrace=0 -DSERVICE_Symbols=0 -DSERVICE_LineNumbers=0 \
- -DSERVICE_Expressions=0"
+ -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
+CFLAGS_mips64_append = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+ -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
+ -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
+CFLAGS_append_libc-musl = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
+ -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
+ -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
do_install() {
oe_runmake install INSTALLROOT=${D}