summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/e17/e-wm/illume-flaunch-fix.patch15
-rw-r--r--recipes/e17/e-wm_svn.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/e17/e-wm/illume-flaunch-fix.patch b/recipes/e17/e-wm/illume-flaunch-fix.patch
new file mode 100644
index 0000000000..5aab3b5dc0
--- /dev/null
+++ b/recipes/e17/e-wm/illume-flaunch-fix.patch
@@ -0,0 +1,15 @@
+--- e/src/modules/illume/e_flaunch.c 2010-02-09 22:33:25.000000000 +0100
++++ e/src/modules/illume/e_flaunch.c 2010-02-09 22:33:25.000000000 +0100
+@@ -97,10 +97,10 @@
+ int num = 0, max, count;
+
+ // FIXME: 3 should become config here
+- max = 10;
++ max = 3;
+ // for now just look for any apps in "category" 'Bar' and add the first 3
+ // FIXME: category should be configurable...
+- bar_desktops = efreet_util_desktop_category_list("System");
++ bar_desktops = efreet_util_desktop_category_list("Bar");
+ if (bar_desktops)
+ {
+ Efreet_Desktop *desktop;
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index 602f78e335..043cc51d58 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "eet evas ecore edje efreet edbus"
LICENSE = "MIT BSD"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r10"
+PR = "r11"
inherit e update-alternatives
@@ -20,6 +20,7 @@ SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch;patch=1"
SRC_URI_append_shr = " \
file://illume-disable-screensaver.patch;patch=1 \
file://wizard-module-skipping.patch;patch=1 \
+ file://illume-flaunch-fix.patch;patch=1 \
"
EXTRA_OECONF = "\