summaryrefslogtreecommitdiff
path: root/recipes/zip
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zip')
-rw-r--r--recipes/zip/zip-native_2.32.bb10
-rw-r--r--recipes/zip/zip.inc19
-rw-r--r--recipes/zip/zip_2.32.bb3
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes/zip/zip-native_2.32.bb b/recipes/zip/zip-native_2.32.bb
new file mode 100644
index 0000000000..cfa4272378
--- /dev/null
+++ b/recipes/zip/zip-native_2.32.bb
@@ -0,0 +1,10 @@
+require zip_${PV}.bb
+
+inherit native
+
+S = "${WORKDIR}/zip-${PV}"
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install zip zipnote zipsplit zipcloak ${STAGING_BINDIR}
+}
diff --git a/recipes/zip/zip.inc b/recipes/zip/zip.inc
new file mode 100644
index 0000000000..8d04bd5f61
--- /dev/null
+++ b/recipes/zip/zip.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Archiver for .zip files"
+SECTION = "console/utils"
+LICENSE = "Info-ZIP"
+
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/zip${@bb.data.getVar('PV',d,1).replace('.', '')}.tar.gz"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
+ 'CFLAGS=-I. -DUNIX ${CFLAGS}' 'INSTALL=install' \
+ 'BINFLAGS=0755' 'INSTALL_D=install -d'"
+
+do_compile() {
+ oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+ oe_runmake -f unix/Makefile prefix=${D}${prefix} \
+ BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \
+ install
+}
diff --git a/recipes/zip/zip_2.32.bb b/recipes/zip/zip_2.32.bb
new file mode 100644
index 0000000000..0c57235c2f
--- /dev/null
+++ b/recipes/zip/zip_2.32.bb
@@ -0,0 +1,3 @@
+require zip.inc
+
+PR ="r1"