summaryrefslogtreecommitdiff
path: root/recipes/xfce-base/libxfce4util_4.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xfce-base/libxfce4util_4.6.1.bb')
-rw-r--r--recipes/xfce-base/libxfce4util_4.6.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/xfce-base/libxfce4util_4.6.1.bb b/recipes/xfce-base/libxfce4util_4.6.1.bb
new file mode 100644
index 0000000000..6c40d2d50f
--- /dev/null
+++ b/recipes/xfce-base/libxfce4util_4.6.1.bb
@@ -0,0 +1,27 @@
+# libxfce4util OE build file
+
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xfce4-dev-tools "
+PR = "r1"
+
+inherit xfce46
+
+EXTRA_OECONF += "--disable-dependency-tracking --disable-static --with-broken-putenv=yes"
+
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
+ # The line below expands to the list of headers that native makefile
+ # would install. Complain and/or fix if it's not portable enough
+ for file in $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+
+}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"