summaryrefslogtreecommitdiff
path: root/recipes/webkit/webkit-gtk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/webkit/webkit-gtk/configure.ac')
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac33
1 files changed, 24 insertions, 9 deletions
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index 5bc1781698..be29495cff 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -1,8 +1,8 @@
AC_PREREQ(2.59)
m4_define([webkit_major_version], [1])
-m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [90])
+m4_define([webkit_minor_version], [3])
+m4_define([webkit_micro_version], [1])
# This is the version we'll be using as part of our User-Agent string
# e.g., AppleWebKit/$(webkit_user_agent_version) ...
@@ -35,7 +35,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
dnl # Libtool library version, not to confuse with API version
dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=19:1:17
+LIBWEBKITGTK_VERSION=20:0:18
AC_SUBST([LIBWEBKITGTK_VERSION])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -389,7 +389,7 @@ AC_MSG_RESULT([$enable_ruby])
# check whether to enable HTML5 sandbox iframe support
AC_MSG_CHECKING([whether to enable HTML5 sandboxed iframe support])
-AC_ARG_ENABLE(ruby,
+AC_ARG_ENABLE(sandbox,
AC_HELP_STRING([--enable-sandbox],
[enable HTML5 sandboxed iframe support [default=yes]]),
[],[enable_sandbox="yes"])
@@ -569,6 +569,22 @@ AC_ARG_ENABLE(fast_mobile_scrolling,
[],[enable_fast_mobile_scrolling="no"])
AC_MSG_RESULT([$enable_fast_mobile_scrolling])
+# check whether to enable FileReader support
+AC_MSG_CHECKING([whether to enable FileReader support])
+AC_ARG_ENABLE(file_reader,
+ AC_HELP_STRING([--enable-file-reader],
+ [enable support for FileReader [default=no]]),
+ [],[enable_file_reader="no"])
+AC_MSG_RESULT([$enable_file_reader])
+
+# check whether to enable FileWriter support
+AC_MSG_CHECKING([whether to enable FileWriter support])
+AC_ARG_ENABLE(file_writer,
+ AC_HELP_STRING([--enable-file-writer],
+ [enable support for FileWriter [default=no]]),
+ [],[enable_file_writer="no"])
+AC_MSG_RESULT([$enable_file_writer])
+
# check whether to enable code coverage
AC_MSG_CHECKING([whether to enable code coverage support])
AC_ARG_ENABLE(coverage,
@@ -636,17 +652,12 @@ if test "$enable_introspection" = "yes"; then
G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
- GIRDIR="$($PKG_CONFIG --define-variable=prefix=$prefix --variable=girdir gobject-introspection-1.0)"
- GIRTYPELIBDIR="$($PKG_CONFIG --define-variable=prefix=$prefix --variable=typelibdir gobject-introspection-1.0)"
-
AC_DEFINE([ENABLE_INTROSPECTION],[1],[Define to enable GObject introspection support])
fi
AC_SUBST([G_IR_SCANNER])
AC_SUBST([G_IR_COMPILER])
AC_SUBST([G_IR_GENERATE])
-AC_SUBST([GIRDIR])
-AC_SUBST([GIRTYPELIBDIR])
# determine the font backend
AC_MSG_CHECKING([the font backend to use])
@@ -807,6 +818,8 @@ AM_CONDITIONAL([ENABLE_XHTMLMP],[test "$enable_xhtmlmp" = "yes"])
AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
+AM_CONDITIONAL([ENABLE_FILE_READER],[test "$enable_file_reader" = "yes"])
+AM_CONDITIONAL([ENABLE_FILE_WRITER],[test "$enable_file_writer" = "yes"])
AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
AM_CONDITIONAL([ENABLE_MATHML], [test "$enable_mathml" = "yes"])
AM_CONDITIONAL([ENABLE_RUBY],[test "$enable_ruby" = "yes"])
@@ -860,6 +873,8 @@ Features:
Fast Mobile Scrolling : $enable_fast_mobile_scrolling
JIT compilation : $enable_jit
Filters support : $enable_filters
+ FileReader support : $enable_file_reader
+ FileWriter support : $enable_file_writer
Geolocation support : $enable_geolocation
JavaScript debugger/profiler support : $enable_javascript_debugger
MathML support : $enable_mathml